Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-30-2007, 12:25 AM   #1
Registered: Aug 2004
Location: Australia,NSW
Distribution: CalculateLinux, FreeBSD, Makulu, Voyager, Bayanihan Linux
Posts: 268

Rep: Reputation: 30
System locale charset Problem With K3B

Hi , Lately when opening K3B I get this error at Startup

"System locale charset is ANSI_X3.4-1968
Your system's locale charset (i.e. the charset used to encode filenames) is set to ANSI_X3.4-1968. It is highly unlikely that this has been done intentionally. Most likely the locale is not set at all. An invalid setting will result in problems when creating data projects.
Solution: To properly set the locale charset make sure the LC_* environment variables are set. Normally the distribution setup tools take care of this."

I have tried searches to see if anyone has similar problem but could not find any.
I am noy quite sure what to do in regards to "LC_* environment variables" to be set or How.
AnyOne Know what I should or can do.
Thanks AnyOne
Old 10-30-2007, 02:19 AM   #2
Registered: Aug 2004
Location: Australia,NSW
Distribution: CalculateLinux, FreeBSD, Makulu, Voyager, Bayanihan Linux
Posts: 268

Original Poster
Rep: Reputation: 30
I found This While Googling & found someone who had the exact Problem as mine & was from same Country,
. " You'll probably find etc/environment empty. If so add :
export LANG=en_GB.UTF-8
export LC_ALL=en_GB.UTF-8

or whatever the Australian locales are."

--Problem Is I cant find the File or Folder "/etc/environment". Could there be another file I could add these to.?

Last edited by browser; 10-30-2007 at 03:38 AM.
Old 06-14-2009, 10:42 PM   #3
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
I am getting the same error

I am getting the same error as you on startup
of K3B
did u ever find out why or how to remedy this

its the first i have ever heard of this error


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
k3b - burning CD's/DVD's with anoter charset/codepage. ErV Linux - Software 1 04-17-2007 12:31 PM
"perl: warning: Setting locale failed." System wide problem Darek84CJ Debian 3 01-25-2006 05:22 PM
C locale and system locale johnnydangerous Fedora 4 04-11-2005 03:37 PM
k3b system configuration problem dnial Linux - Software 1 07-22-2004 02:28 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:41 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration