LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   synaptic help ... (https://www.linuxquestions.org/questions/linux-newbie-8/synaptic-help-163339/)

JMK 03-28-2004 09:23 AM

synaptic help ...
 
Hey all ... just installed synaptic from rpm for fedora 1 and when i come to run it from terminal under KDE i get this message and synaptic freezes upon launch .....

[j@dhcp-204-276832 j]$ synaptic

(synaptic:6442): Gtk-CRITICAL **: file gtkwidget.c: line 1827 (gtk_widget_hide): assertion `GTK_IS_WIDGET (widget)' failed


any ideas how i can solve this or have i gone wrong somewere ??

any help would be greatful

thanks for your time to read this msg :)

spawgi 05-21-2004 06:12 PM

Problems with synaptic
 
Hello,

I got apt and also synaptic. I was initally happy to have such a nice interface and package uninstaller. But now I am kind of annoyed by weird messages while attempting to remove the packages.

I installed 2 versions of realplayer and I was trying to remove them. But if I try to remove them using synaptic, then it gives me a list of 'n' packages that will be uninstalled. These packages include openoffice etc. I have removed one realplayer manually. But synaptic says 2 versions of realplayers are installed. I am confused. Addisional problem is that the realplayer that I have says some other device is using the audio device.

I have mandrake 9.2. Is there any package manager, uninstaller available? GUI is not necessary. Please help.

Thanks,
spawgi

spawgi 05-21-2004 06:16 PM

URPMI
 
I am trying to know how to use urpmi and other tools. I am a newbie. So if I have written something stupid in the last email, I am really sorry.

spawgi

Electro 05-21-2004 07:23 PM

RPM files depend on tons of other RPM files. Those files also depend on other files and so and so. RPM files are nightmare. The rpm manual has options listed that you can disable checking for dependencies. This sometimes works or it makes more problems.

You can use Kpackage to install or uninstall rpm files. Continuously typing "ps ax" at the terminal will give you information what rpm options Kpackage is using to install or uninstall rpm files.

What rpm options did you use to install synaptic or did you just install it through a gui program like Kpackage or other RPM gui installer.

spawgi 05-22-2004 01:17 AM

I tried KPackage. It detected the realplayer packages. I ran KPackage as root. It just hangs after clicking Uninstall. I have mandrake 9.2. Do I need to get any other packages?


Any help?

Thanks


All times are GMT -5. The time now is 05:40 AM.