LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2002, 05:59 PM   #1
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Rep: Reputation: 15
Switching desktops and fstab problem...


Hey guys,

I just installed Slackware (latest version) and I'm now with Gnome but I'd like to switch to other desktops before deciding which one I'll use as my main one. I know there is a command that will allow me to switch from one desktop to another but I don't remember what it is..>_< So if anyone could tell me what to do, I'd really appreciate it.

Another problem is when I try to mount a floppy. I use mount /mnt/floppy and I get a message saying that /mnt/floppy is not in /etc/fstab. I wouldn't mind adding it manually but I don't know what to put in there other than /mnt/floppy. Any ideas?

Thanks in advance.
 
Old 03-10-2002, 09:20 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
xwmconfig will allow you to choose other desktops installed on the system. As far as the floppy, try doing;

mount /dev/fd0 /mnt/floppy or whatever directory you are mounting it to. If you don't have a directory in /mnt called floppy it won't work anyhow so you can either mkdir /mnt/floppy or just mount /dev/fd0 /mnt.
 
Old 03-11-2002, 07:39 AM   #3
adcripps
Member
 
Registered: Mar 2002
Location: South UK
Distribution: Mandrake 8.2
Posts: 103

Rep: Reputation: 15
I read in a book the other day about a command "switchdesk", but never got it to work as of yet - even tried it as root.
 
Old 03-11-2002, 09:27 AM   #4
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
Alright. thanks taz.

adcripps: I think switchdesk only works on some distros or kernels, I'm not too sure..but it didn't work for me neither. :\
 
Old 03-11-2002, 11:23 AM   #5
Artamir
Member
 
Registered: Nov 2001
Location: Canada
Posts: 41

Original Poster
Rep: Reputation: 15
I created the /mnt/floppy directory and still get the same message: /mnt/floppy not in /etc/fstab or /etc/mtab. I get the same message when trying mount /mnt/fd0. I checked in the /mnt directory and I don't see anything.

Any ideas as to what I need to add to fstab or mtab??
 
Old 03-11-2002, 01:16 PM   #6
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
I honestly don't know why fstab makes a difference with the floppy. I don't use an entry and it works the way I described. You may want to do a dmesg |more and look through and see what it's doing when it finds fd0 at startup. If any errors that'll cause a problem. Otherwise, you may want to try specifying the filesystem type with the mount -t command when trying to mount and see if that makes a difference. It would normally give you a filesystem error to need the mount -t option, but you never know. If you want to add a line in your fstab you can. I'm not sure what options you'd wanna use though as i've never tried it. So you may want to do a man mount to read up on options to use for the line;

/dev/fd0 /mnt/floppy auto rw,user,noauto

That's just a really rough, off the top o' my head idear. You'll wanna read up specifically for the floppy. I'm sure there is a post in the forums somewhere you could find about the correct fstab entry.
 
Old 03-11-2002, 09:30 PM   #7
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try:

/dev/fd0 /mnt/floppy auto rw,user,noauto 0 0
 
Old 11-12-2002, 01:59 AM   #8
icyfire
Member
 
Registered: Feb 2002
Location: Bay Area, California
Distribution: Ubuntu
Posts: 110

Rep: Reputation: 15
Quote:
Originally posted by Artamir
adcripps: I think switchdesk only works on some distros or kernels, I'm not too sure..but it didn't work for me neither. :\
switchdesk i believe only works on redhat. i just recently switched to slack 9.0b and i too want to switch desktops. im going to try the xwmconfig.

as for the floppy, what linuxcool said should work.

icy
 
Old 11-12-2002, 09:49 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Icy, just wondering if you noticed the date on this thread? I am thinking that they probably aren't still having issues, but again I can't be sure since it's a good 6+ months ago

Cool
 
Old 11-12-2002, 11:07 PM   #10
icyfire
Member
 
Registered: Feb 2002
Location: Bay Area, California
Distribution: Ubuntu
Posts: 110

Rep: Reputation: 15
i did notice, after i posted it. hehe.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem switching between desktops redhat_marsi Linux - Newbie 2 06-11-2005 04:31 AM
switching desktops glimmy Slackware 3 05-15-2005 10:58 PM
Switching Desktops ? KezzerDrix Ubuntu 3 04-12-2005 11:18 AM
switching desktops corbis_demon Linux - General 2 07-19-2004 03:08 AM
switching desktops citrus Linux - General 8 02-19-2004 04:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration