-   Linux - Newbie (
-   -   Switch back to graphical interface (

revenge80200 06-02-2004 07:31 PM

Switch back to graphical interface
Hello all,

I was doing some reading on how to use Linux, namely the Konsole, and I have run into a bit of a problem. The page said that I was able to hit 'Ctrl+Alt+F1' and 'Ctrl+Alt+F7' to switch between a graphical interface and a text-based on, just like Konsole. The page also suggested that I create another profile to practice with, so I went into Administration and tried to set up another user. When I rebooted the computer, the thing only boots up in the text interface, not the graphical. I tried to get back to the graphical by hitting 'Ctrl+Alt+F7' but all I get is a cursor blinking in the upper left corner.

If anyone could help I will offer my first-born, or much thanks...which ever you care for....

t3___ 06-02-2004 07:41 PM


init 5





to get back into the gui...

edit your default runlevels to have it survive reboots...

ranger_nemo 06-02-2004 07:46 PM

Hmmm... I don't see what could have bonked from what you said you did. Normally, adding a user shouldn't do that.

You can try starting X with "startx". If that works, you didn't do too much damage.

The file that controls whether you boot to the console or to X is /etc/inittab . Check in there to see if it somehow changed. Look for the section that starts with "# Default runlevel.". Read the comments, but you prob'ly want the line after that to say "id:5:initdefault:". If it already has that, then something is wrong.

You can read the boot-up messages with "dmesg | less". See if it says anything is wrong there. Then, you can check /var/log/X-something.log . You'll have to look in the directory to find the correct file.

revenge80200 06-02-2004 07:55 PM

T3...thanks for looking in....

When the computer starts, it asks for a login and next the password.

I tried both fail-safe and linux with and without entering the login. With the login and password for: init 5 I get nothing.

For kde under the same conditions I get:
execve failed for /etc/X11X (errno 2)
giving up.
xinit: No such file or directory ( errno 2 ): unable to connect to X server
xinit: No such process ( errno 3): Server error.

and that is the end of it.

Thanks for helping,

t3___ 06-02-2004 08:05 PM

I hope im not sending you in the wrong direction... but perhaps a bad or corrupted XF86Config file???

Try opening that file with a text editor...

or try running XF86Setup or xconfigurator to recreate the config file...

or maybe someone could suggest a way to dump the results of startx to a log???

revenge80200 06-02-2004 08:41 PM

Any direction you can think of sounds helpful to me

I'll take a look at your suggestions.

Thanks again.

All times are GMT -5. The time now is 03:15 AM.