LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   swig not found on configure (https://www.linuxquestions.org/questions/linux-newbie-8/swig-not-found-on-configure-76724/)

migraineboy 07-28-2003 04:42 PM

swig not found on configure
 
hi,

installed swig 1.3.19 according to instructions. swig executable was placed in default usr/local/bin.
Then...
tried to install gnu solfege 1.4.10 according to instructions:
./configure rendered this:
=====================
loading cache ./config.cache
checking for python... /usr/bin/python
checking python version... 2.2
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking whether make sets ${MAKE}... yes
checking for swig... no
configure: error:
*** You need to install swig. You can find it at *****ww.swig.org
*** and it is probably available in a binary package from the CD or
*** ftp site of your favourite linux distro.
=====================================
swig is installed and solfege's configure script doesnt allow a path option for swig's location.


did how do i make solfege recognize the existence of swig??

thanx

neo77777 07-28-2003 06:48 PM

First of all make sure /usr/local/bin is in your path
echo $PATH
export PATH=$PATH:/usr/local/bin
if the package has shared libs they were prolly installed in /usr/local/lib make sure it is under $LD_LIBRARY_PATH
echo $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
or in /etc/ld.so.conf in this case you need to run /sbin/ldconfig to update /etc/ld.so.cache


All times are GMT -5. The time now is 09:14 PM.