Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-02-2010, 02:13 AM   #1
Registered: Jul 2008
Posts: 60

Rep: Reputation: 15
Swiching Locale(s) to URF-8 in Debian Lenny

In accordance with directives - possibly misunderstood - I have reconfigured the Debian "locales" package; I changed the installed locale from en_US.ISO-8859-1 to en_US.UTF-8 and left the default locale for the system as "none".

So far so good.

In my ".bashrc" file, I have an entry for "LC_LANG".

If this entry is set to "en_US.ISO-8859-1" all my texts are readable on the console but I get warnings like:
Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale

If I change the LC_LANG entry to "en_US.UTF-8", I no longer get these warnings but the screen-display of Midnight Commander (mc) is a real mess. And even man-pages are no longer able to display hyphens (-) correctly.

What have I missed?

Old 04-02-2010, 10:23 AM   #2
LQ Newbie
Registered: Sep 2009
Location: Velika Gorica, Croatia
Distribution: Debian
Posts: 15

Rep: Reputation: 0
Make sure you set LANG variable to en_US.utf-8 and possibly LC_ALL and make sure you have the right fonts installed and used. After you do this and logout, login check the output of locale command...
Old 04-02-2010, 10:33 AM   #3
LQ Newbie
Registered: Jan 2009
Location: Brazil
Distribution: debian
Posts: 16

Rep: Reputation: 1
Usually when I got this messege I use dpkg-reconfigure locales and then I select the one(ones) I am going to use.
Old 04-02-2010, 05:40 PM   #4
Registered: Jul 2008
Posts: 60

Original Poster
Rep: Reputation: 15
Originally Posted by hvulin View Post
Make sure you set LANG variable to en_US.utf-8 and possibly LC_ALL and make sure you have the right fonts installed and used. After you do this and logout, login check the output of locale command...
I tried all of these (and dpkg-reconfigure locales) before posting the query.

The hard facts are:

1. Midnight Commander (which I like and use routinely) does not support utf-8 and turns into a mess when loaded in a utf-8 environment;

2. vim - in a utf-8 environment - offers many hundreds of additional digraphs; but the few digraphs, that I occasionally need (for French or German words), have become difficult to find.


3. After the change to the utf-8 locale, my man pages are littered with unreadable characters.

Given that utf locales are likely to become the default option, I posted the initial query to forestall future headaches. For the present, I can live with complaints that are posted to the console, but cannot live with an unusable Midnight Commander and messed-up man-pages.

I will be grateful for any other advice that will help me to prepare for an unwelcome future.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian: locale problems Kovax Linux - Server 1 06-30-2009 11:01 AM
Locale problems on Debian 4.0 icmp_request Debian 7 07-09-2007 07:19 AM
Swiching from Outlook to ??? alejandroye Linux - Software 5 11-14-2006 10:30 PM
new debian user. need help with scim and locale. damienduff Debian 2 04-05-2005 01:16 PM
setting LOCALE variables in Debian LaoNiu Linux - Software 0 11-10-2004 08:56 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration