LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2004, 12:32 PM   #1
NRHBasher
Member
 
Registered: Mar 2004
Location: East Side Long Beach
Distribution: Red Hat 9
Posts: 32

Rep: Reputation: 15
Swat will not load!


I have installed samba and swat 3.0
also I have read the documents on help
to man pages etc, and configured swat
according to the instructions,
after i also restarted the computer and was
unable to log into root but was able to log into
my regular home acct which i found unusual, the logon
screen would just hang, anyway all I want to do is use my
linux box as a file server, and as a newbie am wondering if there
is anything easier than using swat and samba, i heard of phlak or something like that, the only reason I wanted to use it was because it comes with most distros, and some company might be using it and I will need to learn to support it, but who uses what comes with os's anyway? so now I'm HERE to find out the most popular server program that I can access with a winxp client and is easy for newbies to use until they learn more, I am using red hat 9 and need a lil help, I've already config my host and ip address and dns. i know the nic card works because i can access my xp network from linux and the internet I also made sure to create my shares on my linux box, somebody anybody please help.
 
Old 03-17-2004, 12:42 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
do no double post
you already have this thread active, which you started 2 mins
before this one :
http://www.linuxquestions.org/questi...hreadid=159001

read the rules again please, you agreed to them
http://www.linuxquestions.org/rules.php
 
Old 03-17-2004, 02:10 PM   #3
Tap-Out
Member
 
Registered: Oct 2002
Location: Halifax, NS
Distribution: Ubuntu, Mepis, Debian
Posts: 130

Rep: Reputation: 15
The first thing you should do is make sure SWAT is installed. It doesn't install with Samba by default. To make sure it's installed do the following

Code:
rpm -qa | grep swat
If you see it's installed then you need to turn it on. If not it can easily be found in the RPMS directory of the third RH9 install cd

Once it's installed do the following all as root:

Code:
chkconfig swat on
after that you should restart the xinetd and smb services

Code:
/etc/init.d/smb restart

/etc/init.d/xinetd restart
once all of that is taken care of, launch your web browser of choice. In the address bar type in

a box should come up and ask you for a name and password. Feed it "root" as the name, and use your root account password. From there you should be able to set all your samba needs graphically.

Hope this helps

Tap
 
Old 03-17-2004, 02:20 PM   #4
NRHBasher
Member
 
Registered: Mar 2004
Location: East Side Long Beach
Distribution: Red Hat 9
Posts: 32

Original Poster
Rep: Reputation: 15
being that i'm in kde i turned the survices on in the control panel and it still didn't work, all smb related services are on. now when i connect to the workgroup from xp it says my workgroup is unaccessable and i do not have permmision to access the resources, my eth0 will not activate either all of a sudden.
 
Old 03-17-2004, 03:12 PM   #5
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
use www.webmin.com to access swat... it handles all the module loading for you and covers some areas of samba administration (namely smb user admin) that SWAT does not. try same addy except https

have you opened up all the ports on both ends (on each machine)for samba, windows browsing, etc... I think there are like four if you want samba, Wins, browser service, etc to all work properly.
 
Old 03-17-2004, 07:35 PM   #6
NRHBasher
Member
 
Registered: Mar 2004
Location: East Side Long Beach
Distribution: Red Hat 9
Posts: 32

Original Poster
Rep: Reputation: 15
Thankyou everybody for the support,
I am not giving up and switching back to win2k server
like a sucker linux will not beat me damn it,
I am in the process of reinstalling RH9.0 and trying all the
instructions given.

(sirpimpsalot) i read about the issue of ports etc... but it wasn't
until I read o'rileys book, and it mentioned something about it.
I have to study this a little bit more,

The unfortunate thing is that this is not really documented in the man
pages that well or I seemed to have miss a part, but as a newbie it seems that there are lot of custom commands that must be learned and it seems that you must do alot of research, I personally think it's worth it but seems it makes things harder even if you are a quick learner

I will have more questions after everythings back up.

Once again thankyou.
 
Old 03-17-2004, 08:22 PM   #7
sirpimpsalot
Member
 
Registered: Feb 2004
Posts: 141

Rep: Reputation: 15
easy way to test if it is a ports issue is go into any gui control panel and shutdown the firewall... if it works, you have to open ports.
 
Old 03-21-2004, 10:53 AM   #8
NRHBasher
Member
 
Registered: Mar 2004
Location: East Side Long Beach
Distribution: Red Hat 9
Posts: 32

Original Poster
Rep: Reputation: 15
I got everything to work almost having problems restarting smb and donig command line stuff but I think I can read and figure out whats wrong thanks for the help everyone.....

NRHBasher
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Swat will not load! NRHBasher Red Hat 4 03-22-2004 04:03 PM
swat rjonese Linux - Software 0 07-15-2003 02:26 AM
swat nilbog Linux - Software 5 04-10-2003 05:37 PM
Swat Hone101 Linux - Newbie 4 03-22-2003 01:30 PM
I need help with swat, please jr_906 Linux - Networking 3 03-06-2002 11:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration