LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-23-2009, 12:04 PM   #1
killerkarma
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
SWAT - Can't connect


CentOS 5.3

I have been playing around with Samba for a short amount of time, and wanted to try out SWAT.

I have followed all the guides, first installing using yum, then changing the xinetd.d/swat file to enable it.

service swat
{
disable = no
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
}

I then restarted xinetd and turned swat on in chkconfig.

I also opened the port 901 in iptables. I can successfully telnet to port 901 from a remote machine.

When I try to use a browser to access the machine at http://ip.address:901 it fails to connect or prompt for a password.

Thoughts?
 
Old 10-23-2009, 12:59 PM   #2
mail4vijay
Member
 
Registered: Oct 2009
Location: Delhi
Distribution: CentOS , RHEL
Posts: 214

Rep: Reputation: 33
Quote:
Originally Posted by killerkarma View Post
CentOS 5.3

I have been playing around with Samba for a short amount of time, and wanted to try out SWAT.

I have followed all the guides, first installing using yum, then changing the xinetd.d/swat file to enable it.

service swat
{
disable = no
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
}

I then restarted xinetd and turned swat on in chkconfig.

I also opened the port 901 in iptables. I can successfully telnet to port 901 from a remote machine.

When I try to use a browser to access the machine at http://ip.address:901 it fails to connect or prompt for a password.

Thoughts?
Before that you should enable atleast root user for samba i.e.
Code:
smbpasswd -a root
the restart samba
and then try it from local host as you given only 127.0.0.1 and if prompt for password give root as user and password as your samba password.
....
 
Old 10-23-2009, 04:00 PM   #3
killerkarma
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mail4vijay View Post
and then try it from local host as you given only 127.0.0.1 and if prompt for password give root as user and password as your samba password.
....
Total duh moment. I am trying to access it from another machine, so the only was killing it. Changing that solved it. Thanks.

two points.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SWAT - Could not connect to port 901 brucerowe Linux - Networking 17 09-11-2008 12:45 PM
can't connect to swat techmom SUSE / openSUSE 2 12-06-2006 08:09 AM
SWAT cannot connect verbose Linux - Networking 6 08-09-2004 11:23 PM
Can not connect to SWAT anymore lovswr Linux - Networking 0 11-08-2003 12:16 PM
samba's SWAT...won't connect Robert0380 Linux - Software 7 07-16-2003 05:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration