-   Linux - Newbie (
-   -   Svn + php Web page (

puneetbrar 07-16-2011 02:56 AM

Svn + php Web page
I am a linux newbie
and got into a major problem of setting up svn with php and apache
I have the following softwares in my systems

1. Fedora 13
2. Php version 5.2.17
3. Apache Version 2.2
4. svn client version 1.6.16 i can see them in phpinfo.php
5. svn extension version 1.0.1
6. https installed on apache working fine

Php and apache are working fine there are no issues in that as a project is working

Just Now i have installed svn version 1.6 but when i run a command svn info from command line it works fine i get a message of the revision and its working fine but when the same thing i run from php file or php webpage it gives me the following error

Username: svn: OPTIONS of 'https://someurl/svn/something/something/trunk-new': authorization failed: Could not authenticate to server: rejected Basic challenge (
[0] => Authentication realm: Subversion Login
[1] => Username: svn: OPTIONS of '': authorization failed: Could not authenticate to server: rejected Basic challenge (
The php code is here
$cmd = exec("svn info |grep Revision: |cut -c11- 2>&1", $output, $status);
echo "<pre>";
echo "</pre>";

i have followed the following
and also googled enough but its not working in php web page

Can somebody help me

acid_kewpie 07-16-2011 03:00 AM

why have you posted a poll with this? Why do you seem to think openbsd and freebsd are Linux?? why are you distingushing between rhel and centos? why do you think there could possibly be a "best"?

as for your issue (just running exec from php? Ewwwww, use a proper php interface - you are having authentication problems. httpd is running as a different user as the one you do it manually with so there will be different cached php credentials. Do it properly and you'll be able to properly authenticate easily.

puneetbrar 07-16-2011 03:42 AM

Hi there thanks for that prompt reply first

I Just posted the poll as i got that in my thread and sorry fro calling Free Bsd and open Bsd as linux as i never knew they are not Linux and moreover tha basic diff between RHEL and Centos as per me is RHEL is a commercial Product and Centos is free i may be wrong as i am a newbie kindly correct me

Now my issue is that manual i have tried that also but it does not have that command for svn info as i need to get it from the server that is one and i did all the steps as told by the manual but still

when i tried
print_r( svn_log('', 23) );

Warning: svn_log(): svn error(s) occured 170000 (Bad URL passed to RA layer) URL ' something --password something ' is malformed or the scheme or host or path is missing in /var/www/something/something/deploy_script.php on line 19

can you please help on this

leosgb 07-19-2011 12:01 AM

No option for "not listed"?

cwizardone 07-19-2011 08:53 AM

Slackware. No contest.

All times are GMT -5. The time now is 03:18 PM.