-   Linux - Newbie (
-   -   Suspected Video Card Problems (

Kubrn 05-09-2007 08:20 PM

Suspected Video Card Problems
I have just installed Fedora 6. When I try to boot up after the install it loads the kernel and then loads some other items as well. My screen will go blank and then a little box will pop up that says "input not supported". What happened? Any information will be greatly appreciated. The video card I have is one that is integrated into the motherboard. The motherboard is a asus A8V-VM and the book lists the card as a VIA DeltaChrome Graphics Processing Unit.
Thank you for you help

jay73 05-09-2007 08:40 PM

Do some reseach first; try to determine the horizontal and vertical refresh rates that you monitor will support.

Then boot to the command line:
- select the fc6 boot line from GRUB
- press E
- select the vmlinuz line
- press E
- append init 3
- press ESC
- press B to boot
- when you get to the command line, sign in as "root" and submit the root password
- issue this command: nano /etc/X11/xorg.conf
- locate the "monitor" section and adjust the VertRefresh & HorizSync values so that they don't exceed the refresh rates for your monitor
- also take note of the driver being used under section "Device" - driver.
- save: Ctrl + O ; Enter; Ctrl + X
- now see whether your GUI will start: init 5 (or startx)

Kubrn 05-09-2007 10:37 PM

This is an LCD monitor and I did not find anything on the back of it. I'm looking online to see if I can find some other information. Does an LCD monitor have refresh rates?

masonm 05-09-2007 10:55 PM

LCDs use a different technology than CRTs and refresh rates aren't all that critical with them. I'd suggest looking in xorg.conf to see what video driver is being used.

Try changing the video driver to "vesa" and see if it will work then. Vesa is a very safe driver for video cards. If it works, then you can do some research to find out what driver should be used for your card. If it doesn't work, check the logs to see what went wrong.

jay73 05-09-2007 11:33 PM

True, masonm, but I have a 19" LCD and I can tell you: I haven't been able to install any distro whatsoever without being presented with a blank screen - and invariably, the workaround was to correct the refresh rates. Even after I replaced the driver with vesa (which used to be/ is almost obligatory with Radeon 1x00 cards - no idea whether this applies to Nvdia 7xxx cards as well).

And yes, finding refresh rates is pretty hard to do. My screen came with a super minimal "manual" that didn't specify anything. I spent several hours cruising the net before I finally hit an online shop that did offer this kind of information.

Kubrn 05-10-2007 03:44 PM

Jay I have attempted to follow your instructions as listed. However, I've gotten lost. When you tell me to append init 3 I find no such line under vmlinuz. I have three lines listed the first is. root (hd0,0) the 2nd. kernal /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet the 3rd. initrd /initrd-2.6.18-1.2798.fc6.img Where do I go from here? I think I also found some horizontal and vertical frequency rates for my monitor. Thank you for your help.

jay73 05-10-2007 05:00 PM

I meant this:

kernel /vmlinuz-2.6.18... root=/dev/VolGroup00 rghb quiet init 3

Yours looks a bit different from mine but that's because you use LVM while I don't.

Alternatively, you can leave it alone and wait for the blank screen to come up and then hit

Ctrl + Alt + backspace

As a rule, this has the same effect of taking you to runlevel 3; but on a few occasions I observed that this did not work as expected.

As for the monitor rates, I'll tell you what mine are:
horizontal 31-82
vertical 31-75
These values are monitor specific so yours may be different. I'm just putting these here to give you an idea what needs to appear in your xorg.conf.

Post back if anything goes wrong.

btw, here is another suggestion: right before you actually do the

nano /etc/X11/xorg.conf

you should do:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bu

This will make a back-up of the file before your start editing; it may be a saver should you make an error.

Kubrn 05-10-2007 06:06 PM

I added the init 3 command at the end of vmlinuz and it did nothing for me. however, when I had the box telling me input not supported I did the crtl+alt+backspace and that brought me out of that screen. It appeared to load some other lines and then the screen said auto configuration please wait then the screen would go black and it would say auto configuration please wait and the cycle continued. I also do not get a box or and area to type in my username or password. Thanks.

jay73 05-10-2007 06:19 PM

OK, could you try the same vmlinuz trick? - only this time you append "single" instead of "init 3".

Kubrn 05-10-2007 07:17 PM

Ok I used single and it worked for me. I got to the file and managed to back it up. Once I opened it up and went edit it I didn't find any areas or anything referring to a monitor. this is what I saw
section "serverlayout"
identifier "default layout"
screen 0 "screen0" 0 0
inputdevice "keyboard0" "core keyboard"
end section
section "input device"
identifier "kayboard0"
driver "kbd"
otpion "xkbmodel" "pc105"
option "xkblayout" "us"
end section
section "device"
identifier "videocard0"
driver "vesa"
section "screen"
identifier "screen0"
device "videocard0"
defaultdepth 24
subsection "display"
viewpoint 0 0
depth 24
end subsection

also after I exited the nano program it fedora brought up a screen and tried to configure additional items such as time and my soundcard. Now when I reboot I will still get the Input not supported it's just after it loads additional lines. Again thank you

jay73 05-10-2007 07:46 PM

OK, this is beginning to make sense. If there isn't any monitor section, it's no wonder that the system can't figure out what your monitor resolution is like. I have seen similar botched-up config files from Suse and Mandriva but it's the first time I see one from Fedora. Here is what a proper xorg.conf should look like:


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    FontPath    "/usr/share/X11/fonts/misc"
    FontPath    "/usr/share/X11/fonts/cyrillic"
    FontPath    "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/share/X11/fonts/Type1"
    FontPath    "/usr/share/X11/fonts/100dpi"
    FontPath    "/usr/share/X11/fonts/75dpi"
    FontPath    "/usr/share/fonts/X11/misc"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
    Load    "i2c"
    Load    "bitmap"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
        Load    "GLcore"
    Load    "int10"
    Load    "type1"
    Load    "vbe"

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "be"
    Option        "XkbOptions"    "lv3:ralt_switch"

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ExplorerPS/2"
    Option        "ZAxisMapping"        "4 5"
    Option        "Emulate3Buttons"    "true"

#Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "stylus"
#  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
#  Option        "Type"          "stylus"
#  Option        "ForceDevice"  "ISDV4"              # Tablet PC ONLY

#Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "eraser"
#  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
#  Option        "Type"          "eraser"
#  Option        "ForceDevice"  "ISDV4"              # Tablet PC ONLY

#Section "InputDevice"
#  Driver        "wacom"
#  Identifier    "cursor"
#  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
#  Option        "Type"          "cursor"
#  Option        "ForceDevice"  "ISDV4"              # Tablet PC ONLY

Section "Device"
    Identifier    "ATI Technologies, Inc. ATI Default Card"
    Driver        "fglrx"
    BusID        "PCI:1:0:0"
    BoardName "ATI Technologies Inc RV530 [Radeon X1600]"
    Option "UseInternalAGPART" "no"
    Option "backingstore" "true"
    Option "no_accel" "no"
    Option "no_dri" "no"
    Option "mtrr" "off"
    Option "Capabilities" "0x00000000"
    Option "CapabilitiesEx" "0x00000000"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "on"
    Option "PseudoColorVisuals" "off"
    Option "Stereo" "off"
    Option "StereoSyncEnable" "1"
    Option "FSAAEnable" "on"
    Option "FSAAScale" "1"
    Option "FSAADisableGamma" "no"
    Option "FSAACustomizeMSPos" "no"
    Option "FSAAMPosX0" "0.000000"
    Option "FSAAMPosY0" "0.000000"
    Option "FSAAMPosX1" "0.000000"
    Option "FSAAMPosY1" "0.000000"
    Option "FSAAMPosX2" "0.000000"
    Option "FSAAMPosY2" "0.000000"
    Option "FSAAMPosX3" "0.000000"
    Option "FSAAMPosY3" "0.000000"
    Option "FSAAMPosX4" "0.000000"
    Option "FSAAMPosY4" "0.000000
    Option "FSAAMPosX5" "0.000000"
    Option "FSAAMPosY5" "0.000000"
    Option "UseFastTLS" "1"
    Option "BlockSignalsOnLock" "on"
    Option "UseInternalAGPGART" "no"
    Option "ForceGenericCPU" "no"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    30-80
    VertRefresh    43-75

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies, Inc. ATI Default Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth        15
        Modes        "1280x1024" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth        16
        Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    SubSection "Display"
        Depth        24
        Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
#    InputDevice    "stylus" "SendCoreEvents"
#    InputDevice    "cursor" "SendCoreEvents"
#    InputDevice    "eraser" "SendCoreEvents"

Section "DRI"
    Mode    0666

Section "Extensions"
Option "Composite" "off"

I think the only option left is to generate a new configuration file. You will have to get back to the command line ("single" trick), then sign in as root and do:
If the system complains that the command can't be found, it is actually saying that it is not installed. In that case, you first need to do:
yum install system-config-display
And answer y when the system asks if it is OK to install.
Then run the system-config-display command again.

Alternatively, you can try tweaking your existing xorg.conf by bringing it up (nano /etc/X11/xorg.conf) and putting in:

Section "Monitor"
Identifier "Monitor0"
Vendorname "XXXX" (monitor vendor)
Modelname "XXXX" (type of the model )
VertRefresh XX-XX (put the minium and maximum vertical refresh rates here)
HorizSync XX-XX (put the min. and max. horizontal refresh rates here)
Option "DPMS" "true"

Then, under section "Screen", add this:
Monitor "Monitor0"

I suggest you have a look at my own xorg.conf to find out where these are supposed to be inserted.

Still, you may get further trying the system-config-display first because from the looks of it, your xorg.conf is missing even more (for example, I don't see a single reference to a mouse device).

Kubrn 05-10-2007 08:34 PM

Thank you so much! That got it to work for me. Your help has been greatly appreciated!

All times are GMT -5. The time now is 09:55 PM.