LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-27-2006, 02:30 PM   #1
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Rep: Reputation: 30
Suse10.2 install can't find CDROM. Yet its boots from it??


Trying to install the new open suse. I've burnt the DVD ISO and my PC boots from the DVD, get so far then tells me it can't find the install cdrom... its just booted from it? Same happen with Mandriva 2007 any ideas?

Thanks in advance

Steve
 
Old 12-27-2006, 04:51 PM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 3,117

Rep: Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549
try using

install libata.atapi_enabled=1

as a kernel parameter. You do this from the boot screen that appears when the DVD starts up.
 
Old 12-27-2006, 05:43 PM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by AwesomeMachine
try using

install libata.atapi_enabled=1

as a kernel parameter. You do this from the boot screen that appears when the DVD starts up.
Can you explain what this does? I have seen it several times now, but I have never had a situation where I had to use it.
 
Old 12-28-2006, 02:03 PM   #4
Stevetgn
Member
 
Registered: Jun 2003
Distribution: SuSE10, Mepis,
Posts: 230

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by AwesomeMachine
try using

install libata.atapi_enabled=1

as a kernel parameter. You do this from the boot screen that appears when the DVD starts up.
Cheers mate, I'll give it a try.
It's proof again though that Linux is still not quite there yet for the average desktop user when you have to know about things like that!
 
Old 01-02-2007, 05:47 PM   #5
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 3,117

Rep: Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549Reputation: 549
Quote:
:
Originally Posted by AwesomeMachine
try using

install libata.atapi_enabled=1

as a kernel parameter. You do this from the boot screen that appears when the DVD starts up.
Quote:
Can you explain what this does? I have seen it several times now, but I have never had a situation where I had to use it.
The kernel parameter passes atapi_enabled yes to libata, so if the ata_piix driver loads before libata it won't prevent detection of the CDrom on the atapi bus. This will change shortly, and people won't need that param because libata will provide PATA and SATA.
 
Old 01-03-2007, 06:43 AM   #6
soccermike
LQ Newbie
 
Registered: Jan 2007
Location: Kempten/Germany
Distribution: SuSE
Posts: 3

Rep: Reputation: 0
Am a total newbie to Linux and chose Suse for its apparent easy for beginners. How and when exactly do I have to enter the command?

install libata.atapi_enabled=1

Many Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xubuntu install can't find cdrom - Solved louieb Linux - General 3 11-25-2006 08:42 AM
install: cannot find my cdrom davegod75 Mandriva 1 11-28-2004 09:07 PM
9.1 Install can't find ATAPI CDRom akempo Slackware - Installation 2 10-11-2004 02:05 PM
install fails to find USB cdrom (but boots from it) sslewis Fedora 1 04-14-2004 12:30 PM
9.1 install, boot from cdrom, select source as cdrom, Can't find disk jake555 Slackware 1 10-30-2003 11:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration