LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-22-2004, 12:02 AM   #1
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Rep: Reputation: 15
SuSE - No option to switch from KDE to GNOME...?


Iv been trying to switch from KDE to GNOME and icant seem to figure it out.

GNOME is definately installed but the option to switch to gnome during logon is not there, not is it in system administrator.

can anyone help?

SoulPioneer
 
Old 04-22-2004, 01:52 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Do you mean that when you click on the "session type" button in KDM (the login manager where you type your username and password, pictured here, just to be sure that we're talking about the same screen), GNOME is simply not in that list? Is there anything in the list (meaning, did you install any other WMs than GNOME and KDE, and do they appear?)

If you, at the KDM screen, use the "menu" option to switch to a console login, log into a text session, and then type 'gnome-session' (without the quotes) does GNOME then start?

There is certainly a way to add GNOME to your session list, but I find it so amazing that SuSE did not automate this for you (it's kind of a pain to do), that I would first suspect that GNOME is in fact not fully installed (at least not enough to run a gnome-session). Why do you believe that it is?

Unless, of course, you have autologin set to on, and you never even see the KDM screen in the first place-- in which case you'd have to turn autologin off (so that you'd have the option to choose when you log in), or change the session to GNOME (so that rather than autologging in to KDE you autologged in to GNOME). That would also explain it.

Hope this helps.
 
Old 04-22-2004, 09:58 AM   #3
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Original Poster
Rep: Reputation: 15
Thanks for your reply motub.

Yes you are correct, GNOME simply does not appear in the list. In the list i have the option to select 'Default', 'KDE' and 'Failsafe', in that order. Now i tried default but that just loads KDE.

I did as you said and typed GNOME-session in Konsole and got the following message:

'gnome-session: You're already running a session manager'

Now the above suggested to me that i was already in GNOME, so what i did was logged off, and selected 'KDE' from the menu, logged back in and then typed gnome-session again, i recieved the same message as above.

Autologin is definately off.

GNOME has to be installed... i have checked at least 5 times to ensure that everything required is installed! Actually 6 times now!

And just to be certain i am checking again and listing everything that is installed:

Balsa
bombermaze
bonobo-activation
bug-buddy2
control centre
controlcentre2
control-center-devel
coriander
desktop-date-suse
eog2
esound
evolution
file-roller
gail
gconf
gcon2
gconf2-doc
gdm2
gnome2-SuSE
gnome-applets2
gnome-common
gnome-desktop
gnome-filesystem
gnome-icon-theme
gnome-libs
gnome-media2
gnomemeeting
gnome-mime-data
gnome-panel
gnome-panel-doc
gnome-pilot
gnome-session
gnome-spell2
gnome-terminal
gnome-themes
gnome-utils2
gnome-vfs2
gnome-vfs2-doc
gnome-vfs2-doc
gsmssend
gswitchi
gthumb
gtm
gtoaster
gxsnmp
intltool
libbonobo
libboboboui
libghttp
libglade
libglade2
libgnome
libgnomecanvas
libgnomeprint
libgnomeprintui
libgnomeui
libgsf
libzvt2
metacity
nautilus2
oaf
python-gnome
totem
xsu
yelp

Sorry for the huge list! have i missed something out?

Any other suggestions?

ThrillSeeker
 
Old 04-22-2004, 10:28 AM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
i'm running the ximian desktop here at work, but if i remember correctly it's in the kde control center. probably under /system admin./login manager/sessions/session type.
 
Old 04-22-2004, 10:37 AM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Ummm, if you select KDE from the menu, you're not going to be able to log into GNOME, because-- as the error message states-- you're already running a session manager. What I had suggested is that you use the "menu" button, which-- if I remember correctly-- gives you the option of switching to a console login (thus, stopping X). This would be where you need to try gnome-session; from a console login.

Now, naturally, this will only tell us if GNOME actually works, without solving your problem.

You can solve the original problem in one of two ways.

1) You can add gnome-session to KDM. This is kind of a pain, because it seems like every distribution has a different way of setting up where the list of Xsessions is stored, and subsequently read from.

2) You can switch to GDM. This is easily accomplished by finding GDM Configurator somewhere in your menu (it will most likely be somewhere in your system tools menu, but depending on how SuSE sets up its menus you may have trouble finding it). The program, if it's not in your menu is called gdmsetup. IIrc, you'll need to run it as root, so if you have to run it directly from a terminal, just su to root before entering the command. Once you run it, it will pretty much change your login manager (display manager) from KDM to GDM (at least it always has for me, under every distribution I've used).

And I'm pretty sure that GNOME ought to appear in the GDM menu (it would be awful odd if it didn't), and since KDE is so tenacious that it won't even admit another DE, I'd think it would appear as well.

If you want to take option #1 instead, though, on my PC, the list of DEs/WMs shown in the GDM list is found in /etc/X11/Sessions. It is possible that KDM reads from this folder as well, as I think that they both read whatever is set up for XDM, whether or not one actually uses XDM. However, to add sessions manually, I have to 1) open one of the currently existing session documents as root in a file manager and edit it to reflect the additional WM, and then 2) save it as a new document with the new name. However, this assumes that the DE/WM is not started from a shell script, which both KDE and GNOME are. In which case a symlink or something to the script is necessary.... you begin to see why I said this was a pain, right? Furthermore, even if not started by a shell script, but using a text document in the format already present in the folder, in order to edit it properly in the first place, I find it helpful to check the command that actually starts the dm, which is where it can get even more hairy. Google helps, as does the "which" command. And all of this assumes that SuSE has organized your Xsession files the same way Gentoo has, which I wouldn't bet on under any circumstances. So you'll pretty much have to trawl around until you find them, unless another SuSE user shows up with some more definitve info on that issue.

If I was you, I'd just switch to GDM (which is what I generally do. Even though I'm a GNOME user anyway, it seems like most distros set you up with KDM or some (Mandrake) version of XDM, and I've had nothing but irritation trying to get them set up useably)... it's better looking, too. Admittedly you will lose the nice "switch to console login" feature in the menu, but you'll probably survive that, since we can always just CTRL+Alt+F(1-6) to get a console login in any case.

Hope this helps to some extent... because it really is just that confusing, especially with distros that 1) tweak heavily and 2) lean heavily towards one DE over another-- and SuSE does both.
 
Old 04-22-2004, 12:59 PM   #6
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Original Poster
Rep: Reputation: 15

Firstly, i did as mutub suggested which was to enter ending the session and entering console login. This was achieved by pressing ctrl+alt+f1. I logged in and entered 'gnome-session'. I recieved the following message:

‘(gnome-session:3141): Gtk-WARNING **: cannot open display’

I then logged back into kde and noticed that i seem to have all these options for gnome in the 'menu', such as control panel, but when i opened the panel non of the links actually worked. I then went through the rest of the menu to see what else was there and i come across something i hadnt seen before... 'vte'. This pretty much was a command line console. once VTE had opened i typed 'gdm' and hey presto, Gnome started to load!

However, now i dont know if this is possible but kde and gnome both seemed to be running at the same time. I say this because, as i logged out of GNOME, i saw a 'glimpse' of KDE and then, i proceeded to reboot the system, and GNOME 'switched' to KDE and then rebooted! God knows whats going on!

The funny thing is, GNOME gives me the option to select numerous other desktops at the logon screen where as KDE didnt...

Now after rebooting, i was back at KDE login screen, which really annoyed me because i thought i would get the GNOME logon screen.

But after getting to play with GNOME i am even more intent on using it because to me, it seems a lot better than KDE. Not only that but with GNOME i was able to see my XP box through the LAN which KDE wouldnt allow me to do.

Now i have also opened GDM Configurator and i see no option that allows me to configure GDM so that it loads up.

I have also looked in Login manager as recommended by Rshaw and there is definately no option to select GNOME. however, above login manager, there is 'Linus Kernal', when i clicked on this i recieved the following error:

'The kernel configration could not be read due to the following error:

cannot open /usr/src/linux/arch/config.in for reading

Either your kernel sources contain invalid configuration rules or you just found a bug in the KDE Kernel Configurator.'

Does anyone have any idea what the heck is going on? have i missed something out of the installation?

SoulPioneer

Last edited by SoulPioneer; 04-22-2004 at 01:01 PM.
 
Old 04-22-2004, 03:45 PM   #7
CloudBuilder
Member
 
Registered: May 2003
Location: Netherlands
Distribution: Ubuntu, Puppy
Posts: 386

Rep: Reputation: 30
In my recently installed version suse 9.0 there are only the following
entries :

KDE
WINDOW...
FVWM2
FWM
Failsafe

excuse, but I write it as I remember.

On the other I have GNOME, but I realize I installed it by yast.

I would suggest to try to install GNOME by YAST.

CloudBuilder
 
Old 04-22-2004, 05:39 PM   #8
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Original Poster
Rep: Reputation: 15
Thats how i have been installing gnome. Iv been using yast to select what i want to install and then yast would ask me to insert one of the five CDs...

SoulPioneer
 
Old 04-23-2004, 04:03 PM   #9
CloudBuilder
Member
 
Registered: May 2003
Location: Netherlands
Distribution: Ubuntu, Puppy
Posts: 386

Rep: Reputation: 30
Quote:
Originally posted by SoulPioneer
Thats how i have been installing gnome. Iv been using yast to select what i want to install and then yast would ask me to insert one of the five CDs...

SoulPioneer
http://www.linux.org.uk/~telsa/GDP/g.../starting.html

Perhaps this one will give you some more information.

CloudBuilder
 
Old 05-02-2004, 09:22 AM   #10
kastorff
Member
 
Registered: Feb 2004
Location: Atlanta, GA
Distribution: SuSE 9.3 Pro, Ubuntu Hoary, Vidalinux 1.1
Posts: 65

Rep: Reputation: 15
If one had a perfectly working Gnome environment, and a perfectly working KDE 3.2.2 environment, how would one add the option to select gnome at the kdm logon screen? I believe this is more in line with what the original poster requested, at least the way I read it. I'd be very interested in this answer myself, since no one seems to know how anywhere I've asked.
 
Old 05-02-2004, 10:59 AM   #11
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Has anybody asking this actually read the KDE Help Center help for : Configuring KDM?

I don't even use KDM and I'm reading it. KDE Control Center=>System Administration=>select the Login Manger sub-tool, but instead of opening it, click on "Help" from the third tab on the top of the sidebar to get help about ... configuring the KDM login manager. If the help in the Quick help doesn't help enough, there is a link at the end of it which will take you to the following section in the full manual.....

Quote:
Chapter 4. Configuring kdm

This chapter assumes that kdm is already up and running on your system, and that you simply want to change its behavior in some way.

When kdm starts up, it reads its configuration from the folder $KDEDIR/share/config/kdm/ (this may be /etc/kde2/kdm/ or something else on your system).

The main configuration file is kdmrc; all other files are referenced from there and could be stored under any name anywhere on the system - but usually that would not make much sense for obvious reasons (one particular exception is referencing configuration files of an already installed xdm - in fact when a new kdm is installed, it will actually make use of this possibility if it finds an already installed xdm).
That last is what I said in my previous post: "the list of DEs/WMs shown in the GDM list is found in /etc/X11/Sessions. It is possible that KDM reads from this folder as well, as I think that they both read whatever is set up for XDM, whether or not one actually uses XDM." So at least that is confirmed, and thus my strategy of adding a gnome-session "link" to that folder (if it does not already exist) is in fact reasonable for KDM as well as GDM.

So having read that much, I went further and checked what was going on with my system in terms of these files and paths.

I did indeed find kdmrc in $KDEDIR/share/config/kdm; on my system $KDEDIR = /usr/kde/3.2/ . To my surprise, I also found a directory called "sessions", which is empty. I presume it is not if one actually uses KDM. So now there are two choices; add a shell script to /etc/X11/Sessions or add one to $KDEDIR/share/config/kdm/sessions. There's a third choice as well; in my roaming, I came across /etc/X11/dm/Sessions, which contains entries only for blackbox and KDE. I was all set to get confused, but then I realized the solution: I opened kdmrc and looked at it. It clearly says

SessionsDirs=/usr/kde/3.2/share/config/kdm/sessions

So that's where I'd put new sessions if I was using KDM and needed to add a session. OK, that's not quite true; I'd put it in /etc/X11/Sessions, in case I changed DMs at some point, but this seems pretty clear for those who are going to be sticking with KDM.

You are supposed to be able to add sessions to KDM from the Control Center, according to the Help, but I at least do not have that option.

In any case, what exactly are you supposed to add to whichever folder? A simple shell script (although it can certainly be more complex if you want-- mine is, but then again, I didn't write it, it's what was installed by GNOME or GDM).

Basically it's a text file, and all it really needs to say is:

Code:
#!/bin/sh
/usr/bin/gnome-session/
Feel free to confirm that said executable exists in that location before writing the script. Save it, name the thing Gnome, and make it executable, and it ought to work. If you look in /etc/X11/Sessions and find a full shell script to start GNOME, try copying it to the SessionsDir folder referenced in kdmrc.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switch from KDE to Gnome rockytriton Mandriva 5 07-20-2005 03:02 PM
can i switch from gnome to kde? garyozzy Mandriva 3 06-19-2005 07:21 PM
How do I switch between KDE and Gnome? vinni155 Linux - Software 1 09-10-2004 01:45 AM
switch from GNOME to KDE zbably Mandriva 2 01-15-2004 05:06 AM
Switch from Gnome to KDE Bad_CRC Slackware 1 04-02-2003 06:28 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration