LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SuSE live eval cd - Can't access ext HD (https://www.linuxquestions.org/questions/linux-newbie-8/suse-live-eval-cd-cant-access-ext-hd-373700/)

Dein Vampir 10-16-2005 05:56 PM

SuSE live eval cd 9.2 - Can't access ext HD
 
I've tried out the SuSE Live Eval CD 9.2.
But I can't get it to let me into my external HD (Maxtor one touch)
I know that it recognises it because in the Yast thingy there is something under
system? tab that lets you look at your hardware configuration.
It even identifies it by name Maxtor.
It says the file name is /dev/ata
But when I look for it in the file browse or search function it isn't there.
I tried the help files and couldn't see anything related.

I tried SimplyMepis yesterday and it was clear where to look I'm wondering if I am just not looking in the right place rather than it being an error on SuSE's part.
Can anyone help
Thanks
Anna

SlackerLX 10-16-2005 06:24 PM

Hmmm...
First of all it's either LiveCD or EvalCD not both.
Secondly, boot with "irqpoll" option.
I have Maxtor SATA Fat32 80GB also. Boots only with irqpoll. It probably uses shared irqwith some other device. My shares irq11 together with SB Live!

Dein Vampir 10-16-2005 07:07 PM

Thanks for responding
Sorry the confusion came because when I go to close SuSE down it gives me the option log out as live eval user.
But I have checked my download source and it is indeed live not eval.

I'm not sure what irqpoll is but I took a stab in the dark and booted into suse again on the boot screen I typed "irqpoll"
But everything appears as before.
I went into the "drive" thing in "my computer" and it tells me Nautilus cannot view (or open?) this file.
I went into yast and i clicked "hardware" then "hardware" again and it listed all my devices etc
but still no joy.
It's definately seeing it, its just that I don't know what I'm supposed to do to access it.

DeusExLinux 10-16-2005 10:29 PM

Normally I have had issues with Live cd's not working to their fullest potential.

Post the content of your fstab... it should be located in /etc/fstab ......

you might have to actually mount the drive.

Dein Vampir 10-17-2005 05:38 AM

OK
initially it gave me an error window when I clicked on fstab, then it gave me this
/dev/root / iso9660 defaults 0 0.

I messed around some more and looked in the partitioning tool in YaST to see what it could see.
It gave me the location of all my drives and it appears to be reading how full they are correctly.
But when I look for the HD's I get this message

"There is no action associated with "Hard Disc (/dev/hda2)etc". You can configure GNOME to associate applications with file types. Do you want to associate an application with this file type now?"

or


"Couldn't display /dev/sda1 etc Nautilus has no installed viewer capable of displaying the file"

I did a bit of a google and it seems this is not an unknown problem. And its not just on SuSE and it's not confined to live CD's either.
I have no clue what to do next.

SlackerLX 10-17-2005 05:53 AM

Quote:

Originally posted by Dein Vampir

"Couldn't display /dev/sda1 etc Nautilus has no installed viewer capable of displaying the file"

I did a bit of a google and it seems this is not an unknown problem. And its not just on SuSE and it's not confined to live CD's either.

Common problem of LiveCDs. Again LiveCD is a demo, presentation if you will. Use Eval DVD disk to install suse. During the initial boot press one of F keys (F3 I think?) for bootoptions and enter command "irqpoll"

Dein Vampir 10-17-2005 06:09 AM

I can't burn a DVD on this computer. It can only burn cd's.
I realise you don't like live CD's but that is what I am using and will continue to use to try out distros.

As I said when I googled I was finding this was a problem with other people who had red hat based distros but they all seemed to have it installed on their HD. They were Not using a live cd or dvd.

SlackerLX 10-17-2005 06:18 AM

It's OK to err :p
Don't worry. We'll guide you. Practice makes perfect ;)

Dein Vampir 10-18-2005 07:31 PM

Right now I have posted the fstab thingy like DeusExlinux asked me to.

1.So is there a way I can put the other partitions into fstab? How? I'm not very techie. :(

2.Will this mount them?

3. Is this normal behavour for this particular livecd. Has anyone else tried SuSE livecd 9.2? Did you have this problem?


Thanks
Anna

DeusExLinux 10-19-2005 11:09 PM

1.) Where's the fstab? You need to copy and paste it here, so I can look at it. :)

2.) This in itself won't mount the drive, but, it can lead you to being able to mount the drive. What you'll probably have to do is add the drive into your fstab, it sounds harder than it is.

3.) I've noticed with livecds, they tend to not be as reliable as an installed distro. Not Reliable, they just seem to have more issues... SuSE has always been good, though, so give it a chance.

Dein Vampir 10-20-2005 05:59 AM

Quote:

Originally posted by Dein Vampir
OK
initially it gave me an error window when I clicked on fstab, then it gave me this
/dev/root / iso9660 defaults 0 0.


I posted it below your request in post five
Thanks :)

DeusExLinux 10-20-2005 05:56 PM

sorry about that.. stupid me didn't read the whole thing.. :)

Hmm.. that's all it gives you? it seems you might have to create a mountpoint at then mount the drive on it.. it's gonna take some terminal time1.

Dein Vampir 10-20-2005 07:06 PM

Quote:

Originally posted by DeusExLinux
sorry about that.. stupid me didn't read the whole thing.. :)

Hmm.. that's all it gives you? it seems you might have to create a mountpoint at then mount the drive on it.. it's gonna take some terminal time1.

OK cool, Ive read about there being 6? parts to the info you have to give it. I have read loads but I still haven't found out.

1. How I get the info into the fstab thing.

2. Do I need to put it somewhere else as well either before or after.

When I looked at fstab with my simplymepis live cd it said this.
Quote:

# Static entries below, do not use 'users' option in this area
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /sys sysfs defaults 0 0
none /dev/pts devpts mode=0622 0 0

# Dynamic entries below, identified by 'users' option
/dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000 0 0
/dev/hda5 /mnt/hda5 vfat noauto,users,exec,umask=000 0 0
/dev/hda6 /mnt/hda6 vfat noauto,users,exec,umask=000 0 0
/dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0
/dev/sda2 /mnt/sda2 vfat noauto,users,exec,umask=000 0 0
/dev/sda3 /mnt/sda3 vfat noauto,users,exec,umask=000 0 0
/dev/sda4 /mnt/sda4 vfat noauto,users,exec,umask=000 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,users,dev,ro 0 0
Is this the info I need to give it?
How?
If I can sort this out I will be over the moon.

DeusExLinux 10-23-2005 12:10 PM

To view to the fstab, the easiest way is to open up a terminal and type: cat /etc/fstab..

If you want to edit it, you have to be root... again easiest way is to, in the terminal, su into root and type the name of your favorite editor (kate,gvim,whatever you like..) if it gives you some error about X servers type: xhost local:0

In your mepis cd these are your external hd
Quote:

/dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0
/dev/sda2 /mnt/sda2 vfat noauto,users,exec,umask=000 0 0
/dev/sda3 /mnt/sda3 vfat noauto,users,exec,umask=000 0 0
/dev/sda4 /mnt/sda4 vfat noauto,users,exec,umask=000 0 0
there are about 5 or 6 parts in the fstab, as you can see above.. first you have to tell it what the device is (/dev/sdaX) then, you tell it where to mount (/mnt/sdaX... or whatever you want), next comes the filesystem, (vfat,ntfs, whatever it is) then the options (no auto means no auto mount, users means all users can mount... I stick with defaults,noauto,users) after just put 0 0 (those are zeros)... just add those lines into the fstab, and it should work...

Dein Vampir 10-24-2005 01:21 PM

I appreciate you posting that. :)
I printed it off and used it as a guide when in SuSE.
However it will not let me be root.
I type in su and it takes me to the nextline but as soon as I try to do the other steps it gives me an access/permission denied thing


All times are GMT -5. The time now is 07:54 PM.