LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Suse Linux 8.1 (https://www.linuxquestions.org/questions/linux-newbie-8/suse-linux-8-1-a-296086/)

mario8723 02-28-2005 09:37 PM

Suse Linux 8.1
 
I recently downloaded Mozilla Firefox and it's a tar.gz file. I am extremely new to Linux and have no idea how to install the program. I follow the instructions:
tar -xzvf firefox-1.0.installer.tar.gz
cd firefox-installer
./firefox-installer
I do this through the root bash shell. The problem is after the last part there, ./firefox-installer. When I type that in it gives me an error saying that it can't open the file or that it is already in use. PLEASE help me!

Just as an aside, I did check my manuals and they don't really address the issue. I also checked the man files and they briefly address the tar format.

Also, (I know, I know, damn newbies), how the hell do I start Gnome2? I try to run startx gnome2 from every damn terminal/shell and it won't work. I'm assuming that's because I'm logged in to KDE3 at startup. How do I log off KDE3 and start Gnome2? I ask this because apparently Gnome2 has a program named Nautilus that handles tar files and would eliminate my problem.

Ugh...

Tuvok 02-28-2005 09:50 PM

For Firefox, open the untared folder (using Konqueror), and click the icon that installs it. I suggest you install it in your home directory (/home/mario8723) as user (for the moment). For Gnome, log out of KDE, and when presented with the login manager, change the session (find it by looking the options), select Gnome and login.

mario8723 02-28-2005 09:56 PM

I will try that later tonight. Thanks for the advice! I'll let you know if it worked...

mario8723 02-28-2005 10:56 PM

Another thing...

I bought Suse Linux 8.1 about two years ago. I tried to install it on a previous system under VMWare and it didn't work. It wasn't possible to run any of the GUI interfaces. Being a complete noob I was frustrated. I don't really remember why I couldn't install it under Windows (had 2000) but it didn't happen for whatever reason.

Well, I'm now at the point where I felt I was ready for Linux. In the meantime I have built another machine and figured I would just install Linux on the entire drive on my old machine-over Windows 2000. It worked great and I had no install problems.

My only question is how to update Suse Linux to a more current version. 8.1 is rather old at this point. I know it doesn't have the current kernel and I think they're up to 9.2? I tried inserting CD1 at boot and got it to a point where it's supposed to update the system. The only thing I got was that there were no updates available? How could that be? Any assistance would be greatly appreciated...

Tuvok 03-01-2005 06:39 AM

To update Suse, use YOU (Yast Online Update). Just launch Yast2 as root, and click YOU. But, it will only update it by applying security patches; it will not, for example, update KDE to the latest version. There's a package named apt4rpm that can download and install the latest versions of most packages & applications. You will need to download and install apt4rpm, but it could be frustrating for you (as someone who recently began to use Linux).

If you have broadband, you can install the latest Suse (9.2). You'll just need to download an iso image of about +20 mb, burn it and follow instructions (there are many threads/posts in this forum, search "Suse ftp install"). You could find most of the answers you're looking for by searching it.

mario8723 03-01-2005 04:28 PM

Well I tried again last night/this morning to install Firefox. When I navigate to the folder that has a Firefox-installer file it just opens up in Kwrite. I also tried to open the Firefox-Installer.bin file and it told me that no such file exists? I know I'm doing something wrong and am getting very frustrated. Help!

I also still can't get to the Gnome2 desktop...


All times are GMT -5. The time now is 12:54 AM.