-   Linux - Newbie (
-   -   SUSE Linux 10.1: yast2 crashes with certain modules (

filburt1 07-24-2006 09:30 AM

SUSE Linux 10.1: yast2 crashes with certain modules
I recently installed SUSE Linux 10.1 to be used as a server at home. Everything works fine (in fact, far better than I expected...I didn't even need to install any drivers). However, some yast2 modules crash when I try to open them, including all of the ones regarding software installation.

What I'll do:
  1. Start yast2 from either GNOME or the console (doesn't matter...results are the same) as root
  2. Open one of the modules in question
  3. Window pops up briefly stating "Reading package information" with the module window in the background, finishing its initial startup checklist
  4. Both the checklist window and the status window close with no message and I'm returned to the main yast2 window.
I have searched and others have had this problem, but no threads I found had any working remedies. Ideas? All the other services on the computer work fine, but I want to add PHP modules and the last thing I want to do is start compiling software when I could just click a checkbox instead.

Likely related somehow: the software updater finds no updates. Previously there were about 150, but none installed due to a dependency error, and when I force it to refresh, it still finds no updates.

jschiwal 07-24-2006 09:51 AM

You could try using the rpm command to install the php package. One thing that might be causing the problem is that the rpm database is corrupt. You might try running "rpm --rebuilddb".

filburt1 07-24-2006 10:07 AM


rpm --rebuilddb
...didn't help.

filburt1 07-24-2006 09:18 PM

So, anybody have more ideas?

jschiwal 07-25-2006 01:30 AM

When you said that it also didn't work from the console, did you mean the the yast curses based configuration program wouldn't install packages as well?

Open up a console and su to root. Then enter "tail -f /var/log/YaST2/y2logRPM". Try to install a package in YaST2. If this log doesn't give enough details try "tail -f /var/log/YaST2/y2log" instead.

If this doesn't provide any answers, I think that you may need to repair your system by booting up with the first install disk. Select Install, and then Repair. It seems to me that some program or library file is corrupted, but details from the y2log might indicate something else.

filburt1 07-25-2006 01:30 PM

When I run it from the console, I would show the same popup (Loading package information) and then the console prompt would show up...without even a caret so I need to exit SSH and reconnect.

It's getting even more screwed up, so I'll probably do a repair. If I run the repair from the DVD (I burned one DVD, not five CDs), will it blow away my home directory along with anything in /srv, or will it just reinstall the necessary system files it thinks are broken?

jschiwal 07-25-2006 03:42 PM

The repair item is in the install area, which probably isn't the best place for it. Don't go as far as installing. You should see it just after the license pops up. You can go to advanced and perform the section that you want. I think there is a base system check. If not, select the software installation check, however this one will take longer to complete.

However doing a backup of your /home and /srv partitions might be a good idea just in case.

BotKeeper 08-12-2006 08:48 AM

I had some problems with YaST packages mamagement windows disappearing. I ran yast2 from the command line and could see the cause of my problems (unresolved symbol). I downloaded the latest update RPMs (full RPMs, not patches or deltas) for Yast and package managment. Installed them with the rpm -Fvh *.i586.rpm *.noarch.rpm command. All the package management work fine.

All times are GMT -5. The time now is 10:35 PM.