-   Linux - Newbie (
-   -   SuSE kernel update /sbin/lilo (

hindenbergbaby 12-05-2003 10:00 AM

SuSE kernel update /sbin/lilo
I just did the SuSE 8.2 kernel/kernel source update. I know in theory I should really get a whole new kernel, but I'm getting SuSE 9 for Christmas, and with my master's program finally finishing up, I just don't have time to go through compiling a kernel (I'm a newb) right now. So I'm just going to wait and do the 9 upgrade on the 26th :)

Anyway, I did the 2.4.20 update via YAST2, and it gave the message that I am supposed to execute /sbin/lilo before rebooting (everything installed correctly, from what I can tell). Well, I don't use Lilo to boot (I use Grub) but I tried it anyway, and it says /sbin/lilo is not executable. Did my update take? Is there anyway I can tell? Was that something I only needed to do if I used lilo? If not, is there anyway I can fix it so that I can GET the upgrade to take?

Confused and befuddled.

Pcghost 12-05-2003 11:52 AM

The section in the SuSE 9 manual dealing with this claims Grub auto detects the kernel. I would examine the boot loader settings in the control center (or manually edit grub.conf) and see if the references are set to the newly patched kernel.

aaa 12-05-2003 12:07 PM

The update should have worked. Running lilo is needed for lilo only, you need to do that with any changes you make to it. With grub you shouldn't need to run stuff to apply.
Check your configuration file to make sure everything's ok. You should have another entry there for your old kernel just in case the new one doesn't work.

hindenbergbaby 12-05-2003 01:11 PM

Great... thanks!


All times are GMT -5. The time now is 12:05 AM.