LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Suse dvd Kaffeine (https://www.linuxquestions.org/questions/linux-newbie-8/suse-dvd-kaffeine-441428/)

Fredstar 05-03-2006 09:51 PM

Suse dvd Kaffeine
 
Hello all!!

Im trying to get dvd support in suse linux 10.1 for kaffeine player.

I have downloaded and installed

dvdcss2
dvdread
dvdnav

and installed. However, when i go to play dvd it still tells me that the xine engine does not support the dvd. any help appreciated.

thanks

jschiwal 05-03-2006 09:59 PM

You will need to download the library packages also. The http://rpm.pbone.net is the best place to find them. If you want to play you DVDs or MP3s, then choose the packman packages. For example:
A nice feature of this site is to check your dependencies and fetch any needed packages at the same time.

Fredstar 05-03-2006 10:08 PM

Quote:

Originally Posted by jschiwal
You will need to download the library packages also. The http://rpm.pbone.net is the best place to find them. If you want to play you DVDs or MP3s, then choose the packman packages. For example:
A nice feature of this site is to check your dependencies and fetch any needed packages at the same time.

Im sorry, isnt the library included when i compiled the src.rpm? Im not really that good at rpm based systems.

Also i downloaded and installed the packagees off of packMan, is there a way to add them as a resp. for yast to use?

thanks

jschiwal 05-03-2006 10:38 PM

I didn't realize that was the case. Where did you find the source? I don't know if these libraries are indeed included or not, so you will want to check.

Another thing to try is to execute "sudo /sbin/ldconfig". Sometimes an installation installs a new library path but doesn't run ldconfig.

Spudley 05-04-2006 07:45 AM

The problem is that Suse supply a crippled version of Xine (Kaffine is a front end for the Xine player), which won't play encrypted videos, even when the codec libraries are installed.

You need to update Xine with a version direct from the Xine website (http://xinehq.de), that doesn't include Suse's modifications.

Hope that helps.


All times are GMT -5. The time now is 03:08 AM.