-   Linux - Newbie (
-   -   SUSE 9 YAST2 cannot mount / during floppy install (

cryptosporidium 02-27-2004 04:35 PM

SUSE 9 YAST2 cannot mount / during floppy install

I am trying to install SUSE 9 onto a laptop without a CDROM drive. I created the floppies with the modules on it, and I can get the install started over FTP. However when I partition the disk I get an error saying could not mount / to hdab or somesuch. It says I can ignore this and continue or restart, but restarting achieves nothing. So I ignore and eventually the install fails because YAST2 seems to copying the files into the swap partition!

How can I get out of this?



sirpimpsalot 02-27-2004 06:22 PM

details details. the error message is critical. write it down and report back.

partitions would be listed like hda1, hda2, hda3 (for the first physical hard drive) or hdb1, hdb2 (for the 2nd physical hard drive)... so saying the error message was cant mount / to hdab makes no sense.

cryptosporidium 02-28-2004 05:12 AM

YAST2 installer cannot mount /dev/hda2

Thanks for the reply.

YAST2 finds the disk and offers to partition it according to the following:

/dev/hda1 374.4Mb for swap
/dev/hda2 10.8Gb for / reiser

it formats the drive, but then complains:

"could not mount /dev/hda2/ to /mnt/. you can continue if you know what you are doing, but, to prevent damage to your file systems, it is safer to reboot".

Obviously rebooting doesn't change anything.

I came across a post on another site that said this might be because of / being reiser and to try ext3. I did - no difference. I tried creating the partitions with partition magic 8 (support for linux partitions) but no change.

I ca ignire the message but swap gets the install and evetually fails when full.



sirpimpsalot 03-01-2004 11:31 AM

hmmm. thats kinda strange that yast would choose to put the swap partition first - I did three suse installs this weekend and all put the swap partition last. normal convention would be the opposite. I can practically garantee that is your problem.

I would try selecting "custom partitioning/expert" and build the partitions yourself.... BUILD THE ROOT / PARTITION FIRST with ext3 so that it appears like this

hda1 / ext3 8.0 GB
hda2 swap swap 1.0 GB

also make the partitions slightly different in size (very important - make the swap 1 GB) to ensure that the old partitions are not getting reused and just formateed (I beleive that is what was happening previously - it would explain....)I think yast will do that if you have all the necessary partitions in place.

also, why was the install trying to build/mount a /mnt partitions? you did choose "new install" when the yast install program started, right?

cryptosporidium 03-03-2004 04:54 AM

OK, I tried this:

/ as ext3 8.0gb
swap 1gb

same result:

'could not mount partition /dev/dha1 to /mnt/' you can continue if you know what you are doing, but, to prevent damage to your filsystems, it is better to cancel and reboot'


cryptosporidium 03-03-2004 10:03 AM

The only thing I can think that is in anyway non-standard is that the Tosh laptop I am installing on has a USB floppy with legacy support

cryptosporidium 03-03-2004 10:08 AM

I have also tried bumping up the size of swap to 3gb to se what happens and the install still fails when it runs out of space.

I am trying manually loading the IDE drvers to see if this changes anything.

The odd thing is that if I abort an install and retry with differen settings from scratch ie reboot the machine, YAST2 finds the partitions I created before.

EG right now its asking me if I want to format /dev/hda1 8.0Gb for / with resier (although last time I selected ext3 for /) and the 3.0gb is selected for swap.


cryptosporidium 03-03-2004 10:12 AM

If I try an update installation YAST2 complains that there's no root

sirpimpsalot 03-03-2004 11:42 AM

Ifound this article on the suse portal.... use it to look at your partitions after yast has claimed to have already partitioned your drive... perhaps it is running into some errors it doesnt know how to handle... this will let you verify and if necessary recreate the correct partitioning sceme over again if it is erroeous..


During the installation with YaST2, you can view the information of the partition table. For this purpose, start the installation and wait until the first graphical YaST2 menu appears (language selection). Press the key combination ALT+CTRL+F2 (you can use ALT+F7 to return to the YaST2 installation program). A black screen with an input prompt will appear. Now enter the command:

fdisk -l

The output will look as follows:

Disk /dev/hda: 255 heads, 63 sectors, 7476 cylinders
Units: cylinders of 16065 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 638 5124703+ b Win95 FAT32
/dev/hda2 639 7476 54926235 f Win95 Ext. (LBA)
/dev/hda5 639 1403 6144831 b Win95 FAT32
/dev/hda6 1404 2168 6144831 b Win95 FAT32
/dev/hda7 2169 2933 6144831 b Win95 FAT32
/dev/hda8 2934 3698 6144831 b Win95 FAT32
/dev/hda9 3699 4463 6144831 b Win95 FAT32
/dev/hda10 4464 5228 6144831 b Win95 FAT32
/dev/hda11 5229 5993 6144831 b Win95 FAT32
/dev/hda12 5994 6758 6144831 b Win95 FAT32
/dev/hda13 6759 7476 5767303+ b Win95 FAT32

Since the range from hda1 to hda4 is reserved for primary partitions and logical partitions start from hda5, this example shows that the first two partitions are primary partitions and the other partitions are logical partitions. Furthermore, the column System shows that the second partition is an extended partition.

Now analyze your own partition table. The following are possible results:

You have already created 4 primary partitions and no extended partitions. You will have to repartition your hard disk, because there is no other way of creating any additional partitions. For example, delete one primary partition, replacing it with one extended partition containing logical partitions.
You have already installed four primary partitions including one extended partition that, however, does not have any free space left. You need to delete one or several of the last partitions, replacing them with a logical partition for Linux.

On the command line (to which you have switched with the key combination ALT+CTRL+F2), start fdisk in interactive mode:

fdisk /dev/hda

If your hard disk is not connected to /dev/hda, replace this part of the command with the respective data.

The program fdisk will display an output similar to the following and an input prompt:

The number of cylinders for this disk is set to 1245.
There is nothing wrong with that, but this is larger than 1024
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs

Command (m for help):

You can use the key "p" to view the table once more.
Use the key "d" to delete partitions. When using this function, you will be asked for the partition number to delete. If, for example, you want to delete /dev/hda13, enter the number "13".
The key "n" creates new partitions. In the first step, you will be asked whether you want to create a primary (p), extended (e), or logical (l) partition. For primary and extended partitions, the program will ask for the partition number to use (1-4). In the next step, the size of the new partition is determined. You can adopt the proposed value of the start cylinder with Enter. Determine the end cylinder, for example, by entering "+500M" for a size of 500 MB. If you want to use the entire remaining space, simply confirm with Enter.
The key "w" causes the modified partition table to be written to the hard disk, after which the fdisk program is terminated.
The key "q" terminates the fdisk program without writing the modified partition table.

After you have modified the partition table in this manner, reboot your system with the key combination CTRL+ALT+DEL, thus making sure the modified partition table is read and used by YaST2.

Now start the installation of SuSE Linux. Reject the partitioning proposal of YaST2 and select your hard disk. A list of all partitions on your hard disk will be displayed. Select the partition prepared for SuSE Linux.

Note: If your extended partition also contains logical partitions for Windows operating systems, make sure the extended partition bears the Id "f". You can view the partition table with the key "p" to check if this is the case. If necessary, change the setting with the key "t".

sirpimpsalot 03-03-2004 11:55 AM

this might sound crazy, but also change your bios setting for "plug and play os" to NO if it is set to yes...

bhampton 03-09-2004 02:34 PM

Suse 9 Install - could not mount partition
I am trying to perform a new installation on a complete drive with Suse 9.0 professional and am getting the identical errors as described in this thread:

'could not mount partition /dev/dha1 to /mnt/' you can continue if you know what you are doing, but, to prevent damage to your filsystems, it is better to cancel and reboot'

I've tried taking the actions described in the thread to no avail. Anyone have any other ideas?


cryptosporidium 03-09-2004 03:49 PM

what machine are you trying to install on? I have a Tosh 3480CT laptop

bhampton 03-09-2004 04:18 PM

I'm installing on a generic white box (Computer Builder's Warehouse) with an AMD 756 Viper processor and a Western Digital WD205AA IDE hard drive (20GB). Nothing else on the system.

Raid 03-13-2004 05:02 AM

The Solution!
I wonder if you guys are still having troubles... well anyhow, I'll tell you the fix.. I tried alot of things, but I smacked myself in the head when I found out the error! First, here's how I found out the error, I pressed Ctrl-Alt-F2 to enter Console Mode (during the YaST2 error), and though, I'll mount it myself!! 'cause well, as you know, the entire YaST2 is in a RAMDisk, so it tries to mount the directory /mnt/ to a device (the harddisk), so that when it writes to /mnt/ it redirects it to the HardDisk.. (it wasn't writing to swap at all, it was writing to the ramdisk, that's why it ran out...) anyway, alls clear right?... Well, I tried to do the Mount in console mode, and it said "kernel does not support 'type' file system", or something or other, and I was like 'wha??', then started cursing 'why would it set itself to Reiser when it doesn't even support it??'.. turns out, you probably read the same readme on their ftp, and for floppy mode of installation, says you need at least module 1 and 3 (module 3 is network, module 1 is needed).. well, it's true, for downloading it, you do need module 3, but! You also need module 4! Module 4 is the HardDisk modules (starting to make sense now?), you also probably realized that you need to enter manual installation mode as well.. You'll find that loading the appropriate file system (probably reiser since it defaults to that, or whatever you plan on using), and it'll work fine! Oh... and I know it works, 'cause I'm in it right now! (P.S. I don't think the order of the partitions matter, as long as one is marked 'swap' and the other a linux..) Have Fun!

bhampton 03-14-2004 08:51 AM

SUSE 9 YAST2 cannot mount / during floppy install
I got around the problem but in a completely different manner. I installed RedHat 7.1 that I had available which installed fine. Then I re-ran the Suse 9.0 install and it completed without error. I haven't had time to figure out *why* it worked but I'm on to another issue. Now I'm trying to figure out how to connect to my wireless network. Much as I dislike the MS Monopoly, I'm starting to see why it's going to be quite a while before Linux is any real threat.

All times are GMT -5. The time now is 10:33 AM.