LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SuSe 9.0 --> Start without Xserver? (in console mode?) (https://www.linuxquestions.org/questions/linux-newbie-8/suse-9-0-start-without-xserver-in-console-mode-222547/)

DATA_OK 08-26-2004 04:41 AM

SuSe 9.0 --> Start without Xserver? (in console mode?)
 
Hi,

I´m looking for the option to start my SuSe 9.0 without the XServer in console mode!
Unfortunatly i didn´t find the option in yast.

Where can I configure this?

Also when KDE starts my first user is logged in. I don´t want that.
How can i change this?


Thanks for help

Mega Man X 08-26-2004 04:59 AM

Hi there DATA_OK!

Quote:


I´m looking for the option to start my SuSe 9.0 without the XServer in console mode!
Unfortunatly i didn´t find the option in yast.
Where can I configure this?

To login in text mode, open a terminal, login as root (type "su") and edit your file called "inittab", located at /etc.

You'll find a line like this:
Code:

id:5:initdefault:
Changing the number from "5" to "3" will give you a text login next time you boot into SuSE.
Quote:


Also when KDE starts my first user is logged in. I don´t want that.
How can i change this?

About the user auto-login thing, go to YaST2 >> Security and Users >> Edit and Create Users.
When there, click into your user (the one with auto-login) and choose "Expert Options >> Login Settings". You should be able to turn the auto-login off for this user.

Hope it helps. Good luck!

rjlee 08-26-2004 05:05 AM

Edit the /etc/inittab file, and change the initdefault setting to the runlevel you want. 3 is multi-user with network on SuSE.

I think you can also change the runlevel setting in the “runlevel editor” in YaST but I may be wrong.

I can't remember where the setting to log in the first user is; it's definitely an option in the YaST installler, so I'm assuming it'll be in YaST somewhere. But it only happens if you have a default runlevel of 5 anyway (starting the X server, logging in on boot), so changing the default to 3 will stop this behaviour as well.

By the way, in console mode you can type
Code:

startx
to start X windows.

DATA_OK 08-26-2004 05:33 AM

Hi,

thanks for your quik answer.

That was a great help. TANKS AGAIN.

some additional infos for people who maybe looking for the same:

1. autologgin:
- the config File is:
/etc/opt/kde3/share/config/kdm/kdmrc
- log in with root in KDE and there is a controll center / system management / loggin management / "make it easy" (sorry bad translation from German, is the last "page") and there is the autologgin button (enable / disable)

2. in yast (with root again) is the register system / runlevel editor / and then set xdm (X Display Manager) to activate "no"

have a nice time.

greetings from the cold Germany

DATA_OK

Mega Man X 08-26-2004 05:39 AM

Cool! I'm glad you've also shared info. That's the Linux spirit of sharing :)

Bitte schön. Vom kalten Schweden:)


All times are GMT -5. The time now is 10:18 AM.