LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2004, 02:53 PM   #1
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Rep: Reputation: 15
Unhappy Suse 9.0 cannot change default init from 3 to 5


Ok, i installed suse 9 on this machine the other day, and everytime i log int it starts in default init of 3. I have gone into YaST and configured the runlevels to be at 5 at startup, also, I have gone into the /etc/inittab file and verified that the default level is 5
*enclosed*



# The default runlevel is defined here
id:5:initdefault:

# First script to be executed, if not booting in emergency (-b) mode
si::bootwait:/etc/init.d/boot

# /etc/init.d/rc takes care of runlevel handling
#
# runlevel 0 is System halt (Do not use this for initdefault!)
# runlevel 1 is Single user mode
# runlevel 2 is Local multiuser without remote network (e.g. NFS)
# runlevel 3 is Full multiuser with network
# runlevel 4 is Not used
# runlevel 5 is Full multiuser with network and xdm
# runlevel 6 is System reboot (Do not use this for initdefault!)
#
l
So, My question is where do i proceed from here? How can i make the system go into runlevel 5 by default? PLEASE HELP

Much thanks.
 
Old 03-03-2004, 03:14 PM   #2
gregaryh
Member
 
Registered: Jan 2004
Location: Utah USA
Distribution: SuSE Pro 9.0
Posts: 43

Rep: Reputation: 15
You could try adding the run level to your boot menu.
Edit the /boot/grub/menu.lst file and add a 5 to the end of the kernel line under the default Linux menu item:

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x317 splash=silent desktop hdc=ide-scsi hdclun=0 showopts 5
initrd (hd0,2)/boot/initrd
 
Old 03-03-2004, 04:43 PM   #3
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
cool, i will try it out and post the results. Any idea of why it boots to level 3 instead of 5 even with default set correctly?
 
Old 03-03-2004, 04:48 PM   #4
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
do you have a graphical session manager installed? xdm/kdm/gdm
 
Old 03-03-2004, 05:01 PM   #5
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
i am using kdm, but what is a graphical session manager?
 
Old 03-03-2004, 05:04 PM   #6
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
kdm is a graphical session manager. I thought maybe that would be the problem....perhaps kdm isn't being loaded at startup? You should be able to verify this with Yast. Sorry I don't know much about graphial logins, so this is about the best I can do to help.
 
Old 03-03-2004, 05:06 PM   #7
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
ok... thank you , will chek YaST again
 
Old 03-03-2004, 05:31 PM   #8
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
hrm... looking in YaST and I get nothing, at least nothing that i havent seen before. any specific place i should look?
 
Old 03-03-2004, 05:44 PM   #9
gregaryh
Member
 
Registered: Jan 2004
Location: Utah USA
Distribution: SuSE Pro 9.0
Posts: 43

Rep: Reputation: 15
A display manager is what is loaded by X windows to tell it what your settings are (KDE, Gnome, etc) kdm is the KDE Display Manager which is the default on SuSE.

You can check your display manager in YaST under System -> editor for /etc/sysconfig files

expand the Desktop tree and then the Display manager tree and select DISPLAYMANAGER

Make sure kdm is set or which ever you prefer.
Click finish to make sure the settings are kept.

Alternativiely you can edit the displaymanager file found in the /etc/sysconfig directory.
emacs /etc/sysconfig/displaymanager

After making changes to this file you have to run SuSEconfig --module xdm then SuSEconfig --module kdm to apply them.
This is what mine looks like:

## Path: Desktop/Display manager
## Description:
## Type: string(kdm,xdm,gdm,wdm,console)
## Default: ""
#
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="kdm"

## Type: yesno
## Default: no
#
# Allow remote access to your display manager (kdm only for now)
#
DISPLAYMANAGER_REMOTE_ACCESS="yes"

## Type: string
## Default: no
#
# Allow remote access of the user root to your display manager
#
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"

## Type: yesno
## Default: yes
#
# let the displaymanager start a local Xserver
# set to "no" for remote-access only
# set to "no" on architectures without any Xserver (e.g. s390/s390x)
#
DISPLAYMANAGER_STARTS_XSERVER="yes"
## Path: Desktop/Display manager
## Description: settings to generate a proper displaymanager config
## Config: kdm3
## Type: list(root,all,none,local,auto)
## Default: auto
#
# KDM_SHUTDOWN determines who will be able to shutdown the
# system in kdm. Valid values are: "root", "all", "none", "local", "auto"
#
KDM_SHUTDOWN="auto"

## Type: string
## Default:
#
# space separated list of users for which icons should be shown in KDM
# if empty, then take system defaults
#
KDM_USERS=""

## Type: string
## Default:
#
# Special greeting words in kdm
#
KDM_GREETSTRING=""

## Type: string
## Default:
#
# define the user whom should get logged in without request
#
DISPLAYMANAGER_AUTOLOGIN=""

## Type: yesno
## Default: no
#
# Allow all users to login without password, but ask for the user
#
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
 
Old 03-03-2004, 05:47 PM   #10
gregaryh
Member
 
Registered: Jan 2004
Location: Utah USA
Distribution: SuSE Pro 9.0
Posts: 43

Rep: Reputation: 15
Also, are you sure Xwindows is not just crashing on boot? Check the /var/log/XFree86.0.0.log file for any errors.
 
Old 03-03-2004, 09:23 PM   #11
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
ok, first off, thanks for all of your help everyone so far. I have done several of the suggested things and here are my results thus far... On the editing of the GRUB config file 1) the system will now boot directly to kdm, unfortunately it will not give me the login prompt that i so desire... It just boots to whoever was last logged on 2) I checked the configuration for the desktop manager In YaST it is set to boot kdm default... 3) I checked my /var/log/XFree86 log file, and, truthfully I dont know what to look for to find out if it is crashing or not...
thanks
 
Old 03-03-2004, 09:45 PM   #12
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
Quote:
Originally posted by Damoek
3) I checked my /var/log/XFree86 log file, and, truthfully I dont know what to look for to find out if it is crashing or not...
Anything following (EE) is cause for concern
 
Old 03-03-2004, 11:33 PM   #13
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
ok, check... nothing after (EE)
 
Old 03-04-2004, 11:09 AM   #14
gregaryh
Member
 
Registered: Jan 2004
Location: Utah USA
Distribution: SuSE Pro 9.0
Posts: 43

Rep: Reputation: 15
When KDE boots, can you log out? Does it show a login screen then?
Also check that the value of DISPLAYMANAGER_AUTOLOGIN is set to null ( "" ) in your /etc/sysconfig/displaymanager file.
Also, have you created multiple users? I found that before adding more than one system user to passwd file I was automatically logged in on KDE.
 
Old 03-05-2004, 09:06 AM   #15
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Original Poster
Rep: Reputation: 15
I had only one user to begin with, then i switched to a second user to begin. The auto login feature is quite disabled. And the strangest thing happened today, after being in the winxp install i rebooted, went to suse, and the login manager came up in runlevel 5 , but for some reason it would not let me log in with either of my users. After three tries it kicked me back to what i assume was runlevel three where i had to login from the command prompt... this problem just gets stranger...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change default Kernel in Suse 9.2? j_savoy SUSE / openSUSE 4 04-20-2005 11:40 AM
Where is my init.d and default runtime directory chakkerz Slackware 2 02-23-2005 08:19 AM
init not found error after change in RAM drakish Linux - Hardware 1 01-15-2005 03:43 AM
SysV-Init scripts...change order during bootstrapping? tsw Mandriva 2 07-02-2004 09:39 AM
init default and httpd frankie_g Linux - Networking 3 06-04-2002 02:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration