-   Linux - Newbie (
-   -   SuSe 8.2 firewall / router config (

domacious 08-19-2003 01:32 PM

SuSe 8.2 firewall / router config
I've installed Suse 8.2 and run Yast to configure the firewall.
The machine is leasing an IP on eth1 from my cable modem and eth0 is my internal interface that is up routing no problem (currently using VNC to log into firewall box internally).
Yast shows the firewall as setup with the external interface as eth1 and the internal interface as eth0.
I'm planning on running a web server on this so I've enabled http and https as well as ssh as available services then on the final config screen I've selected only to forward packets and do masquerading then to log only critical dropped and accepted packets.
It will "start the service" however I'm unable to route to the Internet from my internal machines. Public DNS will not resolve nor will public IP addresses.
Moving from Redhat to Suse I've noticed some differences. There is no rc.firewall in the rc.d directory, I've tried to run iptables -L forward to give some sort of idea but it comes back that Table does not exist (do you need to insmod?)

I'm lost. I've tried to manually edit the /etc/SuSEfirewall2_final but got lost in that document too.

mindnumbed 08-20-2003 04:56 PM

firstly, check if you are using iptables or ipchains. that would explain why iptables appears to be dead.
secondly, check if you are using a firewall config tool like shorewall, that would simplify it for us to solve your problem.

domacious 08-20-2003 06:59 PM

I'm using the firewall control center in Yast. It's not the shorewall labeling that RedHat uses and I do not recall how to determine if iptables or ipchains is being used. I've tried both iptables -L and ipchains -L and neither come back with a valid response.

All times are GMT -5. The time now is 10:50 AM.