-   Linux - Newbie (
-   -   Suse 10 DVD-Rom issues (

Rylinkus 02-18-2006 11:40 AM

Suse 10 DVD-Rom issues
Did a quick install of Suse 10.0 last night. Now Im having a few issues regarding the CD/DVD writer. For one I can't install from the CD anymore. In trying to install a few things that didnt get installed during the actual install it merely prompts me to insert the Suse 10 CD 1, while the Suse 10 DVD is clearly in the drive. Saving that K3B also doesn't recognize my burner in anyway. So what am I missing? Thanks in advance.

imemyself 02-19-2006 01:58 AM

Can you access anything from CD's when you put them in? You might try looking in somewhere like /media/cdrecorder or /media/cdrom or /media/dvdrom. If there aren't any folders named something like that then maybe SuSE isn't mounting the drive. At the console try run mount. It should show you everything that is mounted on the system. If there isn't anything that looks like it might be related to a DVD or CD drive, try running (as root)

mkdir /media/cdrecorder

mount /dev/cdrecorder /media/cdrecorder
mount /dev/cdrom /media/cdrecorder
mount /dev/dvd /media/cdrecorder

The first command just creates a folder for the drive to be mounted to(if its not already there). The mount commands use device names that SuSE seems to be using for my CD-RW/DVD-ROM drive on my laptop. If one of them works, it should say something about read only file system when you run the command, and you should be able to see the files on the CD/DVD that is in the drive(a disc will probably need to be in the drive for any of the mount commands to work) in the /media/cdrecorder folder.


Rylinkus 02-21-2006 05:02 PM

Special device does not exist.

Anyone have any other suggestions?
Thanks in advance

imemyself 02-21-2006 05:55 PM

Does the drive show up in BIOS? And you installed SuSE from this drive, correct? Did it ever work after you installed SuSE?

Rylinkus 02-21-2006 06:09 PM


Originally Posted by imemyself
Does the drive show up in BIOS? And you installed SuSE from this drive, correct? Did it ever work after you installed SuSE?

Shows up in bios.
The drive works fine under Windows, and yes, I installed Linux from it. But it would be nice to be able to use it to install some pacakges from, Gaim, amongst others. And being able to burn an ISO while linux is running would be wonerful as well.

imemyself 02-21-2006 10:57 PM

I'm really not sure then. That does sound pretty odd. What's the manufacturer/model of the DVD drive? Is it anything too "exotic"?

RedShirt 02-22-2006 07:31 AM

Can you post your fstab for us please?

Rylinkus 02-22-2006 06:19 PM

It's probably something obvious thats the issue. But I dont really know. Ignore the glut of Windows drives. They have their purposes.


/dev/hde2 / reiserfs acl,user_xattr 1 1
/dev/hde1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdf1 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hdf2 /windows/E vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hdf3 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdf4 /windows/G vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hdg1 /windows/H ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hde5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvdrecorder /media/ subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
none /subdomain subdomainfs noauto 0 0

RedShirt 02-22-2006 06:50 PM

you have a dvd recorder drive, set to "noauto", which means it isn't mounted automatically. in order to mount it, you would also have to do "mount /dev/dvdrecorder", none of the above would work. You have to mount by exisiting name. If you remove the noauto, when you boot, it will mount anything in the drive automatically.

PS, it is also set to "ro" which is read only. Won't be doing much burning on that guy.

Rylinkus 02-22-2006 07:00 PM

So just to be sure Im going to set this up right the proper way to edit that line to get it to automount said drive would be?

RedShirt 02-22-2006 07:07 PM


dev/dvdrecorder /media/ subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
should become:

dev/dvdrecorder /media/ subfs fs=cdfss,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
Give that a shot.

Rylinkus 02-22-2006 07:09 PM


Originally Posted by RedShirt
Give that a shot.

Will do. ;)

imemyself 02-22-2006 08:43 PM

edit: oops, had an old version of the page and forgot to refresh.

Rylinkus 02-23-2006 07:53 PM

Worked for me for all of a day. Now Im back to the same issue. Discs not mounting. Which would be wonderful as there's a few apps Im trying to battle dependency issues with and I KNOW the files are right there, I merely cant access em.

/dev/dvdrecorder /media/ subfs fs=cdfss,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

RedShirt 02-23-2006 09:05 PM

So... it worked... then stopped? Did anything change? The drives still work just fine in Windows, right?

And your fstab remains the same...

How about manual mounting? Does that work? "/mount /dev/dvdrecorder" what is the error you get if it doesn't?

All times are GMT -5. The time now is 10:42 AM.