LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-30-2005, 01:02 PM   #1
KLund1
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
Unhappy Suse 10 Dual boot Raid, Windows XP not loading


HI All
I have a Win XP Raid 0 set up (pata, not serial). I have installed Suse 10.0 on a third drive, that I use for back up. It was about half full, formated in FAT32. Suse installed without any problems on a separate partition it made on that drive. Now when I boot the computer, only the Suse boot screen in displayed, there is no menu option for windows. Suse 10.0, Suse XEN, Suse Repair are my only options.
When I installed Suse, it gave a warning message about my RIAD 0 set may not be recognized. It said the raid drivers were identified as "hde" and "hdg". While installing Suse, it displayed it was installing itself on "hdc" (while in windows this was my e: drive, third back up drive)
I'm kind of think it has to do with the MBR and/or Grub. But I know very very little about MBR (master boot record) for a raid 0 set up (there are 2 drives, how can there be 1 record?), and nothing about Linux or Grub command line instructions or programing. Any help would most appreciated. I need to get back to windows. I was just wanting try Linux for the first time.
KLund1
 
Old 11-30-2005, 02:24 PM   #2
lostn1slinux
Member
 
Registered: Nov 2005
Distribution: Suse, Debian, Ubuntu, Mandriva, DSL, Fedora, Redhat Entrerprise
Posts: 113

Rep: Reputation: 15
The way i read your problem is that You installed Suse on a back up drive that does not carry the MBR. This being said Suse doesn't reconize your Raid setting so it didn't have access to your MBR when it installed so it made it's own on the drve to which you installed it. If the drive to which you installed it doesn't have an OS on and just being formatted in FAT32 Suse doesn't reconize a windows partiotion. This is just a shot in darkbut hope it helps in some way
 
Old 11-30-2005, 02:48 PM   #3
KLund1
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Unhappy

Hi,
Thanks for such a fast reply.
What you say makes sense. How do I get Grub to see the windows partition, which is on the RAID 0 set up drives (C: & D: - NTFS), not on the back up driver Suse is loaded(E: -fat32, now with a Linux partition and Linux swap partition)?
Can I move the MBR to the raid drives. How would I do that? Would it kill the Raid set up?
By the way the Raid is executed by a Silicon Image Raid controller card, model 680. SI has no Linux drivers for this controller.
Thanks again for you help
 
Old 12-01-2005, 12:39 AM   #4
lostn1slinux
Member
 
Registered: Nov 2005
Distribution: Suse, Debian, Ubuntu, Mandriva, DSL, Fedora, Redhat Entrerprise
Posts: 113

Rep: Reputation: 15
It al depends on what you want to do. Do you wan to run a dual boot or do you want to go back to windows? If you want to go back to windows and don't require the third drive then disconnect it. This will get you back into windows. IF you want linux off the drive you'll have to format it whole. i am not an expert however in the past it has been the only recourse i have taken with dual booting.
 
Old 12-01-2005, 01:37 AM   #5
KLund1
LQ Newbie
 
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the reply.
I want to get windows back. But I still want to keep the 3rd drive connected. I have my back up data there. I can reinstall Linux again later, after windows is back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Announce : Installing a Windows/Linux Dual Boot on Intel ICH5R SATA Raid TheBlackUnicorn Linux - Hardware 3 12-01-2006 01:46 PM
Howto install linux with BIOS RAID 0, dual boot with windows? jbmigel Linux - Newbie 5 10-28-2005 03:52 AM
SuSE 9.1 XP Dual boot issue… Hung at < loading Grub > LinuxHawk Linux - General 1 10-29-2004 02:09 AM
Need Help Loading Windows XP & SuSe Linux version 8.2---to Make a Dual Boot System Howerton Linux - Newbie 7 09-23-2004 02:49 PM
Windows/Linux dual boot with RAID 0 Arbitor Mandriva 2 03-29-2004 09:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration