LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SuSE 10.0.0, ATI Radeon 9200: TV out yes, video NO... how to? (https://www.linuxquestions.org/questions/linux-newbie-8/suse-10-0-0-ati-radeon-9200-tv-out-yes-video-no-how-to-390005/)

Thanh-BKK 12-06-2005 09:40 PM

SuSE 10.0.0, ATI Radeon 9200: TV out yes, video NO... how to?
 
Hello :)

After tinkering and messing with my Linux for little over a week now, i finally got not only the Dual Boot (thanks to helpers here!)figured out, but also (almost!) the TV-out.

I downloaded the ATI proprietary driver, it took me several attempts to install it untill right now it pretty much works. I get picture on the TV, ok.

BUT when i play a video (DVD, or saved mpg, avi, whatever) in Xine (Kaffeine), this will NOT output on the TV screen. The place where the video should play stays black (or rather, a VERY dark blue).

The setup in the driver is as "clone mode", however after a restart that checkmark has disappeared, yet it works, except the video.

How can i get video to show on the TV too? Because that's the main purpose of having the TV connected :)

Thank you in advance for any advise.....

your Thanh

Thanh-BKK 12-08-2005 01:51 AM

halfway there - initial problem solved, BUT........
 
Hello :)

If my boss knew that i spend half my worktime googling for Linux issues on my home machine.... oh my god. Lucky she's never in the office :)

So i found a partial solution: Adding this line to the xorg.conf:

Option "OverlayOnCRTC2"

But now it's all the other way round and a little difficult. So to start:

When i start the PC with the monitor on and the TV diconnected (i have three video devices going into one TV - my PC, the satellite receiver and my home stereo/VCD player via a switch, it's mostly switched to the sat), Linux starts normal and fine with the correct resolution and all. But when i then connect the TV, no way to get any picture on there. The driver option "TV on/off" doesn't work at all.

When i start the PC and have the TV connected from the very beginning, it starts with the splash screen much smaller than the monitor but fullscreen on the TV, once KDE is up, it's WAY too bright and with too low resolution on the monitor but ok and fullscreen on the TV. The option "TV on/off" works in this mode, yet turning it "off" doesn't put the monitor back to "normal".

Tricky: When starting the PC with TV disconnected (disconnected = TV video-in switched to sat) and AFTER THE INITIAL SPLASH SCREEN, when it starts the second phase of booting Linux) flicking the switch to "PC", i get good picture with correct resolution on the monitor AND on the TV. Here, when using the "TV on/off" option, i can turn it OFF but not back on.

In any mode, when there is picture on the TV, i can now watch video on the TV. BUT no longer on the monitor! Exactly backwards from before - now it stays very dark blue on the monitor while it plays nice on the TV.

Of course with the TV off, it plays nice on the monitor.

Now, in Windows the ATI driver has the option "Theater Mode" which, as soon as a video is played, automatically puts it into fullscreen mode on the TV but keeps it small on the monitor. I can then minimize it and keep working on the PC while the video plays fullscreen on the TV.

And THAT way i would like it on Linux too :)

I googled for hours, yet found no usable solution. It almost always deals with two monitors or a laptop screen plus a monitor, yet in my case it's a monitor and a TV. i am sure there must eb a way since Linux is so configurable.........

Anyone knows how to do it..?

Thanks in advance......

your Thanh

mtnorbeach 01-16-2006 04:41 AM

Yeah, I'm having the same problem. Thanks so far though Thanh, is a good start. M


All times are GMT -5. The time now is 03:21 PM.