LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   superkaramba on Debian (https://www.linuxquestions.org/questions/linux-newbie-8/superkaramba-on-debian-267201/)

phoenix_wolf 12-16-2004 06:49 PM

superkaramba on Debian
 
Greetings

I have just dl superkaramba with apt-get install. but did not work on the theme that I wanted so I checked it's version superkaramba -v it is
Qt: 3.3.3
KDE: 3.2.3
superkaramba: 0.33

Well what I need is version 0.35
I tried to update it doing apt-get update and it did not update I also did apt-get install superkaramba
and it said that I had the latest version.

well I know that is not true
Now a while ago I tryed to dl it then install it but I got some errors doing it the long way

any enuf of that How do I update using apt-get or do I have to dl the latest version and install it using ./config

Thank you all

tripmix 12-16-2004 06:59 PM

That's funny, I used apt to get it and I have v0.35. Maybe you are using woody.
In that case only thing I now of to is update to sarge.

JimBass 12-16-2004 07:05 PM

Getting the tar.gz can solve your problems, or you can change your /etc/apt/sources.lst file. Debian comes in 3 "flavors", stable (servers primarily, or the hyper-nervous), testing (on deck to be stable, probably the most common for desktop use), and unstable (bleeding edge). If you edit the sources.lst and make sure they are set to unstable (same web addresses, just change the designation) you should be able to get superkaramba .35.

****Major Warning******

It may want/need a huge slew of dependencies to get the newest version working. For example, if you're on kde 3.2 (typical for Testing), karamba .35 may require KDE 3.3, which requires ......, which requires ........ so forth and so on until you're download a gig worth of the newest versions of software. Plus there is no guarentee anything on unstable will work at all, let alone with your particular setup. If it works neatly consider yourself lucky. If it doesn't, well, wait a few months and try again.

Please post again if you encounter more problems.

Peace,
JimBass

phoenix_wolf 12-16-2004 08:56 PM

#deb file:///cdrom/ sarge main

deb http://mirrors.kernel.org/debian/ unstable main
deb-src http://mirrors.kernel.org/debian/ unstable main

deb http://security.debian.org/ unstable/updates main


ok the words in red were (testing) I changed them (is that what I was to do?) well if not it worked to a degree

I updated superkaramba to 0.35

now when I try to open somthing it gives me this
Could not find mime type
application/octet-stream

Now I tryed this to see if I could get mime
apt-get install mime
Reading Package Lists... Done
Building Dependency Tree... Done
W: Couldn't stat source package list http://security.debian.org unstable/updates/main Packages (/var/lib/apt/lists/security.debian.org_dists_unstable_updates_main_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Couldn't find package mime
ok then it says run the update so here goes
apt-get update
Hit http://mirrors.kernel.org unstable/main Packages
Hit http://mirrors.kernel.org unstable/main Release
Hit http://mirrors.kernel.org unstable/main Sources
Hit http://mirrors.kernel.org unstable/main Release
Err http://security.debian.org unstable/updates/main Packages
404 Not Found
Ign http://security.debian.org unstable/updates/main Release
Failed to fetch http://security.debian.org/dists/uns...86/Packages.gz 404 Not Found
Reading Package Lists... Done
W: Couldn't stat source package list http://security.debian.org unstable/updates/main Packages (/var/lib/apt/lists/security.debian.org_dists_unstable_updates_main_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.

What have done wrong here?

phoenix_wolf 12-16-2004 09:30 PM

well I got it I had to change the bottem back to testing

deb http://security.debian.org/ testing/updates main

if that is not it plz tell me

However SuperKaramba works so far


Thank you all

p0z3r 12-21-2004 03:05 PM

Quote:

Originally posted by JimBass
For example, if you're on kde 3.2 (typical for Testing), karamba .35 may require KDE 3.3, which requires ......, which requires ........ so forth and so on until you're download a gig worth of the newest versions of software.
Superkaramba will run on KDE 3.1 and up. There is some functionality that may not be there for 3.1 users as some of the code is #if def'ed out so that it can compile.
Just wanted everyone to know that we are trying to remain as backward compatible as possible.
cheers,
-Ryan


All times are GMT -5. The time now is 10:59 PM.