-   Linux - Newbie (
-   -   "Successful install" results in "Boot device not found" (

slackr007 05-31-2005 03:12 PM

"Successful install" results in "Boot device not found"
Ok, so I install FC2 yesterday and although it took me a while to get the IDE devices fixed up right(doesn't pertain to the problem, i don't think), I finally got it "installed successfully". So then I reboot to start linux for the first time and I get(after a long wait to get the IDE devices detected) a

That sounds to me like the MBR is messed up, but I don't know how to check that. I can still run the installer, repair, etc., but I don't know what do do with them. I had the installer set up the partitions automatically, but they looked kinda funny to me; though I don't know much about it. It made three partitions, instead of the two I expected. The first, hda, was the boot sector. The second, hdb was about 80% of the disk, of which I seem to remember seeing something to indicate that this was the system partition. Then the third, hdc, was just there. It was about the same size of hda, and didn't have a label, so I was unsure what it was supposed to be. There was previously a windows partition on this hard-drive, but I had the automatic partitioner delete it. The last bit of info that I can think of to tell you is what I got when I ran the repair thingy on the install disc and tried to do "startx". Here is the result:

Your system is mounted under the /mnt/sysimage directory.

When finished please exit from the shell and your system will reboot

sh-2.05b# startx
hostname: localhost.localdomain: Unknown host
xauth: creating new authority file //.Xauthority
xauth: creating new authority file //.Xauthority

Fatal server error:
Cannot open log file  "/var/log/Xorg.0.log"

Please consult the X.Org foundation support
        at http://wiki.X.Org
 for help.

giving up.
xinit: No such file or directory (errno 2): unable to connect to Xserver
xinit: No such process (erno 3): Server error.

I went to wiki.X.Org and found a thing about configuration problems here, but I tried to execute the xorgcfg in the prompt, but it just said "command not found".

I've still got it up and "running", so if there is anything you need me to do to get extra info, or whatever, just tell me. Any ideas on the problem anyone? Thanks for all the help in advance!

*don't know if this is a no-no, but I posted this thread on the Fedora forum first, but when i noticed there were only 2 people browsing the forum, I decided to copy it to this one also since it does fit in both forums in my opinion. Sory if i'm breakin a rule.:newbie:

bulliver 05-31-2005 04:22 PM

This isn't a Linux problem.

Please chack to make sure all your ide cables are plugged in firmly, and the jumper settings are correct. Also, make sure in your Bios that you have it set to boot from the first ide drive...

slackr007 05-31-2005 09:02 PM

Thanks for replying. I'm pretty sure that they're in correctly because they're always detected on POST. I did notice, however, that I'm using an older p/s with a newer m/b and the motherboard has a 4-pin 12VDC connector on it that the power-supply doesn't have a plug for and my dad's sys-admin said it powers a sub-system on the m/b, but he couldn't remember which one. Could it be that it works with IDE? Anyone know?

All times are GMT -5. The time now is 10:30 PM.