-   Linux - Newbie (
-   -   Success!!! But With Some Problems (

conductor 02-23-2005 09:36 PM

Success!!! But With Some Problems
Howdy Folks,

Well I guess I'm officially a Linuxian:) . I managed to get the Slackware 10.1 installed, hurray! but there some problems when I run Xwindows. It boots into Xwindows alright when I enter the startx command, but that's when things get a bit screwy. It runs like there's some kind of interference, like poor reception on a television, lots of squiggly lines, particularily when I move the mouse cursor and when a new window is opening. Another problem is when I move the mouse, it makes a buzzing noise. One other thing I would like to address at this time is that I don't seem to able to control my sound volume, it seems to be set at full bore. I went into the sound control area but there's no volume control there. I hope someone can help me out with these problems and I'm also hopeful that they don't require too much of a major configuration to fix them, being a :newbie: and all.

Thanks in Advance

Oh one more thing I'm curious about. The OS installed using the first two disks of the four disk set but it didn't ask for the third and fourth disks. Does anyone know what's on these last two disks? I thought they would be part of the full install :confused:

roninja 02-23-2005 10:12 PM

configure your xserver correctly run xorconfig

try using alsamixer to control your sound

disk 3 and 4 are sources and zipslack

If none of this works then post your hardware specs

detpenguin 02-23-2005 11:13 PM

congrats conductor! like roninja said, you might wanna run xorgconfig to set up your x system...
log out of x and as root, type:
and it will walk you through the setup process. you might wanna know your monitor specs first, such as vert and horizontal refresh rates, and which video card you have...if you don't know that, you can just choose 0 which is VESA, i think, which should work for you. it's mostly a question and answer thing, so it's not all that difficult.
if you have problems, let us know, we're always happy to help :)

conductor 02-24-2005 12:27 AM

Thanks detpenguin, roninja,

I've discovered something else but I'm not sure if this relates to the Linux OS. When I reboot back into Windows and go online I have to refresh my IE browser everytime. Could the Linux OS be interfering with or resetting my Windows network settings?


roninja 02-24-2005 12:44 AM

Doesnt seem very likely ive never heard of anysuch thing happening, i also run dual boot and neither OS affects the other

detpenguin 02-24-2005 12:57 AM

i've never heard of it. i multi-boot xp with slackware and suse, and i've never seen any one distro affect the other...

conductor 02-24-2005 05:40 AM

It seems to be alright now, I guess it was just my IE browser acting up. But now I've got more problems, sorry to be such a bother but I'm a taurus and I when I get my teeth into something I'm like a pit-bull, I just can't put it down until I've got it beat. Ok so what's happened since the last time I was here is that I went into xorgconfig and changed all of the settings to try and get rid of the video problems I was having which I managed to do, the only problem then was my mouse wouldn't work so I went back into xorgconfig again and changed the settings again but then I couldn't get back into Xwindows at all, I kept getting fatal errors so I got fed up and reinstalled the system, but this time I chose Gnome instead of KDE thinking the problem may have been the KDE program, needless to say it wasn't, I still had the squiggly lines running up the screen so I went back into xorgconfig yet one more time and just made a few changes which seemed to do the trick. Now the problem is definitely Gnome it caused a fatal error when it was loading and I don't really care for it anyways, so now that I've apparently got my video problems resolved, how can I reset Xwindows to come up in KDE? One more thing, when I first reinstalled the system and booted into Linux I typed in alsa at the root prompt and I was taken to the mixer but after the fatal error with Gnome when I typed alsa at the prompt again I received a bash - bad command reply, so what's up with that? whew! Time to take a breath. Like I said, sorry about all the questions but I'm determined to get this darn thing running smoothly.

Thanks Again & again & again &..................

Wim Sturkenboom 02-24-2005 06:26 AM

In the graphical login screen is somewhere a thing called session. There you can choose another windowmanager. Choose the one you want and login as you always do. It will ask you if you want to make it the default (so say yes). This works on a user-by-user basis (so every user can choose it's own window manager).

roninja 02-24-2005 06:30 AM

to change back to KDE you have 2 options

as root type
rm /etc/X11/xinit/xinitrc
ln -s /etc/X11/xinit/xinitrc.kde /etc/X11/xinit/xinitrc


copy /etc/X11/xinit/xinitrc.kde to ~/.xinitrc

the command to bring up the alsa sound control is
you can also store the settings for it by typing
alsactl store
as root

detpenguin 02-24-2005 11:18 AM

after you boot up and log in, at the prompt type xwmconfig and it will present you with a list of all the window manager/env. on on the one you want, then type startx and you're in :)
whatever one you choose, lets say kde, thats the one that will start when you type startx from now on, until you choose another from xmwconfig...:)

cadkins 02-24-2005 12:16 PM

from my experience, the squiggly lines are coming from either the refresh rates are wrong of the video card is set to the wrong one. Both of which can be fixed from xorgconf.

But as for

I guess it was just my IE browser acting up.
It probably was. Now quit using that nasty bug infested virus sucking browswer :p

Enjoy slack, I'm getting ready to install 10.1 myself :)

conductor 02-24-2005 02:53 PM

What do I type at the root prompt to access my Xwindows screen resolutions, size, colors etc.? Right now my screens are defaulted to 640 x 480 and theres no other choices available to me inside the Xwindows. I've tried reconfiguring my monitor in xorgconfig again and guess what......I couldn't access Xwindows...fatal errors again!....This is getting a wee bit frustrating.

Thanks detpenguin. At least xwmconfig took care of one problem

And thanks to you too cadkins. I'll definitely take your browser advice into consideration once I've got everything else operating properly.

I'm starting to get a little leary of xorgconfig. Is there any way I can reset my xconfigs back to their original settings once I've reconfigured them? I've tried accessing "/usr/etc/X11/whatever" but all I get is "Permission Denied". Obviously there's a bit of a learning curve when it comes to the root access commands eh? Someone in another forum mentioned a root command guide somewhere, know anything about it?

You Know I'll be Back

sh1ft 02-24-2005 03:01 PM


Originally posted by conductor

I'm starting to get a little leary of xorgconfig. Is there any way I can reset my xconfigs back to their original settings once I've reconfigured them? I've tried accessing "/usr/etc/X11/whatever" but all I get is "Permission Denied". Obviously there's a bit of a learning curve when it comes to the root access commands eh? Someone in another forum mentioned a root command guide somewhere, know anything about it?

You Know I'll be Back

The actually fille that xorgconf creates is called /etc/X11/xorg.conf. Since this is a text file you need to oppen it with your favorite text editor, for example vim:

#vim /etc/X11/xorg.conf
If you don't know how to use vim you need to learn at some point or another anyway. There are just 3-4 commands you need to know to actually be able to use it. Try reading this first:

All the lines are well commented and it should be fairly simple to change one without going through the entire xorgconf process again. Just make sure you backup your xorg.conf file before making any changes to it and read the comments carefully.

detpenguin 02-24-2005 04:22 PM

vim is ok, but i found it a bit confusing...i like to use pico, so to edit your xorg.conf file, type:

pico /etc/X11/xorg.conf

and it will can scroll down to find what you wanna change. it's pretty straightforward, like sh1ft points out.
your monitor problems seem to be due to the horiz and vert sync rates...and can be one of the trickier things in slack to configure...but once it's configured you're good to go....can you maybe post your xorg.conf file?

you might wanna check these sites out, too...

conductor 02-24-2005 07:02 PM

I seem to have everything up and running fine except for that dammed screen size resolution. It keeps defaulting to 640 x 480 in the Xwindow with the only other option being 320 x whatever, but I want to go the other way, preferrably 800 x 600 I've tried just about everything in the xorgconfig including entering the horiz & vert sync rates from my monitor's paperwork. I don't understand why I'm not getting more screen size options when I'm in Xwindows. :confused:

I went into xorgsetup from the root prompt but that's only a very limited configuration which doesn't include screen resolution. Surely there's a root command that will take me to another screen resolution setup area. Anyways, like I said, I've tried just about everything in xorgconfig to resolve this little thorn, but not everything, so I guess I'll go back in and try some different settings. Trial & Error, Trial & error.


Oh by the way I tried the vim but it didn't solve this problem and it was very confusing.

All times are GMT -5. The time now is 02:13 PM.