LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   stupid dma not enabling (https://www.linuxquestions.org/questions/linux-newbie-8/stupid-dma-not-enabling-112803/)

Gill Bates 11-05-2003 04:17 PM

stupid dma not enabling
 
i recompiled my kernel (2.4.20) disabling most modules (1's i would never use) and putting others as part of the kerne (1s i would use)l, when i boot the new kernel, it comes up fine, but my root partition (reiserfs) flashs a quick error about DMA being disabled for some reason -> dmesg doesnt show why DMA is being disabled, but when i try to enable it using hdparm -d1 /dev/hdc it gives an error saying it can't, when i boot the old kernel, dma is enabled fine and hdparm can turn it on and off no problem.
does anyone have any idea what could have caused this after a recompile?
suggestions would be handy if u dont know ;)

LogicG8 11-05-2003 04:28 PM

Did you make sure to enable DMA for your IDE chipset?
It's under

MainMenu
IDE\ATA\MFM\RLL support
IDE, ATA, and ATAPI Block devices.


Could you post the exact error message?

Shade 11-05-2003 04:32 PM

Yup. When you recompiled your kernel, you left out support for DMA somewhere. It can be kind of hide and seek with recompiling and getting to know where everything is ;)

It's under ATA/IDE/MFM/RLL Support and then the "block devices" section.

You'll want to enable (assuming the 2.4.22 kernel):
Enhanced Support
IDE/ATA-2
PCI IDE chipset support
Generic PCI IDE Chipset Support
Sharing PCI IDE interrupts support
GEneric PCI bus-master DMA support
Use PCI DMA by default when available

You probably dont' need all of these, but these should work. You may not have left in the last two.

That should do it :)

-Shade

Gill Bates 11-05-2003 06:26 PM

ok i did that and i still got the error message, the screen is moving too fast to be able to read it and dmesg doesnt refer to the error anywhere,
however, with that stuff enabled, hdparm will now work :D thanks, so now i will just ignore the problem and use hdparm to set the disk values during start up.
what are optimal settings or close to optimal settings for it? i know all drives are different but does anyone know what are definite "no gos"?

Gill Bates 11-05-2003 06:32 PM

zoink!! never mind :) - found something else
http://www.linuxquestions.org/questi...ighlight=cdrom

so what about "no go's"?

Shade 11-05-2003 09:40 PM

You mean, dos and don'ts of hdparm?

Well, it's kind of hit or miss ... Sometimes hdparm will let you enable something the drive isn't capable of and you can screw things up.

If your drive is relatively new, I wouldn't worry about it though.

The settings I use :

hdparm -m16 -u1 -c1 -d1 -k1 /dev/hda

-Shade

Gill Bates 11-06-2003 06:18 AM

do -> speeds up performance
don'ts -> cripple the hard drive ;)

i have been experimenting with it, some of the settings dont appear to do anything :confused:


All times are GMT -5. The time now is 04:04 PM.