LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2009, 08:28 AM   #1
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Rep: Reputation: 16
"Strange" thing with Ethernet after computer Shut Down!


Hi to all, ... and greetings to the Linux Community!

Recently i made up a dual boot system with Windows Vista and Linux_AMD64 Debian Lenny on my desktop. I use the default kernel boot parameters in /boot/grub/menu.lst (kernel version 2.6.26-1 , 64 Bit)

The strange thing is that after i shut down my computer, the Ethernet LED on my router stays On, which I assume it means that the network is not automatically disconnected! That doesn't happen with Windows Vista.

I have also installed the same distribution (x86 version) on my Pentium III Laptop and that doesn't happen there either (although i have to turn off my laptop manually, after it halts).

Made some Google search but in vain. I admit i didn't search trough this forum enough ....
Is it some peculiar boot parameter i have to add, or some config file i have to edit ? Or something to do with my hardware ?

In case it might be useful

DESKTOP: Asus M3A AM2+ AMD700 chipset latest BIOS version, CPU Athlon 64 X2 5600+ , GPU NVIDIA 8600 GT ,HDD Western Digital 750 GB

ROUTER : Linksys WAG54G-2 (I use it wired , through LAN)

LAPTOP : Compaq Presario 1700EA (year 2000!)


Thanks in advance!

PS: when i type # lshw all my devices appear recognized
 
Old 01-12-2009, 08:33 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 12,892
Blog Entries: 27

Rep: Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182Reputation: 2182
Hi,

Welcome to LQ!

Is this the lnk LED that remains on?
 
Old 01-12-2009, 08:39 AM   #3
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by onebuck View Post
Hi,

Welcome to LQ!

Is this the lnk LED that remains on?
Hi Gary!

It is the ethernet LED indicator that remains on. Not the ADSL nor the INTERNET. The last two are (supposed to be) always on becouse i have a permanent connection...

PS: amazing fast reply! thank you very much!

Vas
 
Old 01-12-2009, 12:47 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
I expect your ethernet card is "sleeping" rather than being "off".

This is used for things like "Wake on LAN", which means that you may be able to send a "Magic packet" (from anywhere LAN or internet-connected) to the sleeping ethernet card and it'll turn your computer on for you, just as if you had pressed the power button.

Then you could access it remotely, and have it "Power Off" back to "Sleeping and waiting for a Magic Packet". The power consumption of a sleeping card is trivial, so I would not worry about global warming.

I wish I could get this to work with my ethernet card, as it is potentially very useful.
 
Old 01-12-2009, 01:47 PM   #5
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by tredegar View Post
I expect your ethernet card is "sleeping" rather than being "off" ...
Hi tredegar !

Yes, I guess you're right !!
Thank you for your very helpful answer

Vista turns "Off" my Ethernet card by default, when Shut Down. That's why my router's LED is also turned off.

Debian (and some other distros I checked before this one) leaves my ethernet card in "sleeping mode".

Looks like this is a Linux kernel matter, and I must dig very deep!
However I would prefer my Ethernet "Off" ...

Best regards!
Vas
 
Old 01-12-2009, 03:36 PM   #6
GibsoneanNode
Member
 
Registered: Jan 2009
Distribution: Desktop- Debian 4.0
Posts: 43

Rep: Reputation: 16
It is my assumption too that you may have an ethernet card with wake-on-lan support. The Wake on LAN Wiki page has a brief security section providing a cautionary note.

Since, as I understand it, wake-on-lan functionality is activated in part within the BIOS would it be possible to turn it off there? I don't know, I am merely speculating.
 
Old 01-12-2009, 04:25 PM   #7
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by GibsoneanNode View Post
It is my assumption too that you may have an ethernet card with wake-on-lan support. The Wake on LAN Wiki page has a brief security section providing a cautionary note.

Since, as I understand it, wake-on-lan functionality is activated in part within the BIOS would it be possible to turn it off there? I don't know, I am merely speculating.
Hi Gibsonean!
And thanks for the link!

I checked in BIOS first think, but I'm unsure about what some options mean since the manual isn't very helpful! (AMI BIOS)

Here is an excerpt ...

Onboard LAN [Enable]
Configuration options: [Enable] [Disabled]
...
Suspend Mode [Auto]
Configuration options: [S1 (POS) Only] [S3 Only] [Auto]
...
ACPI 2.0 Support [Disabled]
ACPI APIC Support [Enabled]
...

Restore on AC Power Loss [Power Off]
Configuration options: [Power Off][Power On][Last State]

Power On By PCI Devices [Disabled]
Power On By PCIE Devices [Disabled]
Power On By External Modems [Disabled]
Power On By RTC Alarm [Disabled]
Power On By PS/2 Keyboard [Disabled]
Power On By PS/2 Mouse [Disabled]
...

I dont see anything else in there that might be relative to the situation...
As I already mentioned, Vista deactivates the Ethernet card!
Linux should do it also. But how?

Regards
Vas ...

Last edited by vasmakk; 01-12-2009 at 04:28 PM.
 
Old 01-12-2009, 04:36 PM   #8
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
You should have something in the Bios with Network config that says: NIC enabled/WOL OFF or NIC enabled/NO WOL.

It's Wake-up On Lan that's leaving your card on.
 
Old 01-12-2009, 05:18 PM   #9
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by arckane View Post
You should have something in the Bios with Network config that says: NIC enabled/WOL OFF or NIC enabled/NO WOL.

It's Wake-up On Lan that's leaving your card on.
Hi arckane !

Actualy I have a ..
OnBoard NIC OPTROM [Disabled]

under the Onboard LAN [Enable] menu. It is Disabled by default ..
When i make it Enable no more Items appear. Should I make it Enabled ?

Vas
 
Old 01-12-2009, 09:45 PM   #10
GibsoneanNode
Member
 
Registered: Jan 2009
Distribution: Desktop- Debian 4.0
Posts: 43

Rep: Reputation: 16
I would suggest that you not change anything in your BIOS that you are not personally familiar with and comfortable with in changing!

Also, you could do some reading about keywords that you mentioned your BIOS including at The Linux Documentation Project -tldp.org- website. I looked some up for myself and ACPI -Advanced Configuration and Power Interface- appears significant even though you commented that ACPI 2.0 Support is disabled. Though old and “mutually exclusive” from ACPI according to Tux Mobil, the APM -Advanced Power Management- standard predated ACPI and for its age may be of little importance here.

I can only speculate at its relevance, as this entire topic has been beyond my knowledge base, but the acpid daemon's manual page might also be related. It seems to call shell scripts for such activities as the CPU case power button's functionality.

Good luck with your searches vasmakk, I like you have just the opposite situation from tredegar where instead of wanting wake-on-lan support and not having it I appear to have it and could do without it. The difference being, from you to me, is that I have a BIOS option concerning it. I'll be following this thread to see if good information turns up.
 
Old 01-13-2009, 06:25 PM   #11
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Original Poster
Rep: Reputation: 16
Hi friends ... This is me again!

So far ...no luck!

At my laptop i managed to turn my Ethernet "Off" by booting the kernel with acpi=force parameter. And everything worked fine.
Unfortunately this trick has no effect at my desktop ...

See you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE - "Home" and "My Computer" Icons Missing rrrssssss Fedora 7 07-19-2007 06:08 PM
error partioning hard drive "Windows did not shut down completely" emissary Linux - Laptop and Netbook 3 12-25-2005 02:43 PM
Computer is not turning off after "init 0" or "shutdown -h now" f430 Linux - General 5 12-17-2005 03:54 AM
Pipe Jnettop to ethernet "strange problem" ALInux Programming 2 12-12-2005 11:07 AM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-07-2005 12:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration