LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   strange ssh problem (https://www.linuxquestions.org/questions/linux-newbie-8/strange-ssh-problem-761742/)

vinaytp 10-14-2009 12:51 AM

strange ssh problem
 
Hi all..

I am able to start qemu hypervisor in my local machine, But when i try to start it from other host by loging in to my system through ssh it will display following error why is it so...
Code:

Could not initialize SDL - exiting
Can anyone please help me...

Thanks in advance

PEdroArthur_JEdi 10-14-2009 07:50 AM

Hello there

It's a simple problem. SDL is a lib used to render 3D graphics and sound effects. So, it cannot be used across a SSH session cause you will not have access to a framebuffer device by this media.

To bypass this limitation, you must just add "-nographic" at the QEmus initialization's command line. By this, QEmu will not use VGA output, but instead it will act as a standard console application.

Hope I helped you...

vinaytp 10-14-2009 10:18 AM

Great PEdroArthur_JEdi ...

Worked well but when i execute

Code:

qemu -nographic -hda /soft/fedora_qemu/fedora.img
Got an error

Code:

Could not open '/dev/kqemu' - QEMU acceleration layer not activated: No such file or directory
and /dev/kqemu is not there in my system...How can i continue with this...

Please help me....

PEdroArthur_JEdi 10-14-2009 11:43 AM

For using KQEmu, you processor must have the VT (for Intel processors) or the AMD-V (obviously, for AMD processor) instruction set to work properly. If you got one of these two technologies, you may enable the KQEmu by loading the KVM kernel's module:
Code:

# modprobe kvn
And now, you may start QEmu again without seeing the error message.

If you don't have processor with any of these two instructions set, you may still using QEmu, but with little performance. And the message you continue to show every time you start QEmu.

vinaytp 10-15-2009 01:54 AM

Thanks a lot...for your reply


All times are GMT -5. The time now is 05:33 AM.