LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   strange situation with root password (https://www.linuxquestions.org/questions/linux-newbie-8/strange-situation-with-root-password-948953/)

sixto 06-07-2012 02:03 AM

strange situation with root password
 
Hello all,

I am running easypeasy on a eepc from an external usb drive (lack of space and its fun!) everything was going well until..........

i installed the jack server and had to add me to the audio group. i typed up 'groups' but audio was not on the list , so i did an addgroup and it told me 'audio' was already there. so i did a 'usermod -a -G 'group' 'user' and jack was up and running. but now i can log in okay but cannot use my root passwd for anything! it does not authenticate.

I just want to know what i did wrong?
should i have used 'adduser' instead of 'usermod'?
does booting from an usb drive ( its actually an old laptop HD in a usb sleeve) could that have partly caused it?
I could change my passwd but would that cause other problems down the road?
AND Does any of this have anything to do with the passwd problem in the first place?

sorry for this being long , but i'm just very curious and would really like to wean myself off windows.

Thank you all in advance. Sixto

Slackyman 06-07-2012 02:33 AM

When you say that you can't use your root password does it mean that you cannot run as root anything from your account or that you cannot login ,e.g. in a console, as root?

sixto 06-07-2012 03:07 AM

Thank you for a quick reply Slackeyman.

Yes i can log in but once inside i cannot 'sudo' anything in the terminal, cannot install any software or do anything where i have to be root, but i can log in!

Sixto.

sixto 06-07-2012 04:01 AM

One more thing it tells me is that im not part of the 'sudoers' group.

how did i get thrown out of that group?

thanks.

sixto 06-07-2012 04:28 AM

ok fixed it yay!

kinda 'sudo' works now but 'su' does not.

went into recovery mode to a root prompt and added 'me' to the admin group.

but how did i get kicked out of that group?

anyway. another day my friends! thanks for the guidance.

Slackyman 06-07-2012 04:12 PM

Check even the content of the sudoers file.
Check even if (for some strange accident) the SU_WHEEL_ONLY present in /etc/login.defs is erroneously set to yes.


All times are GMT -5. The time now is 02:42 AM.