-   Linux - Newbie (
-   -   Strange mouse behaviour (

J_Szucs 03-27-2003 01:39 AM

Strange mouse behaviour
Today I had to replace my monitor and from that time on my mouse behaves strangely in xwindows (in blackbox and KDE, too):

It is as if some windows (or controls) 'reserve' the mouse for themselves: once I click on such a window or control, every subsequent clicks seem to activate that window or control, even if the mouse pointer is not over that in the given moment.
Sometimes left mouse clicks are ignored when the mouse pointer is not over the control that 'reserved' the mouse.

I know this is not a hardware error: when a control 'reserverves' the mouse for itself and clicks by the left mouse button are ignored, there are still some controls that can always be activated by the left mouse button: e.g. all buttons or icons on the panel.

Texicle 03-27-2003 01:51 AM

Sounds like your mouse focus is all screwed up. You should be able to adjust the focus settings for your mouse within KDE or Blackbox or whatever other WM/DE you're using. You might also want to take a look through your /etc/X11/XF86Config file for good measure to make sure nothing's changed. When you installed your new monitor did you reconfigure you XF86Config to accept the new horiz/vert refresh rates? If you did there might be something in there that's causing the problem, but I'm almost certain it's your focus settings. Check around through your settings and see what you can find on your mouse. Hope this helps or at least points you in the right direction.:D

J_Szucs 03-27-2003 03:15 PM

I do not know which are the focus settings in XF86config. Could you help me?

Meanwhile the situation became more serious than by the first sight: my mouse got completely mad in Linux, so that I had to return to winDOS - it is a shame.

I already tried the following tools several times with no use:
- Sax2: I set the correct settings with it (it even knows about my Genius net mouse pro, but also tried many more mouse drivers), but the last time I could not leave sax2 the normal way: the exit button did not work (even if activated by the keyboard). So I had to kill it. However, it seemed to save the changes, but the mouse still s*cks, and now Sax2 no longer starts.
- Sax1: Says it is for XF86 v3. So far as I know I have XF86 v4, so I should use sax2 (if I could).
- Yast1: calls sax
- Yast2: only has screen settings under "X11 settings"
- XF86conf: I only want to configure my mouse, but this tool asks a lot of other questions to which I do not know the answer. I do not want to screw up my display settings, too. Display settings are critical in my case, once I almost killed this monitor (flashing from behind) when screwed them up.
- editing XF86config manually: I have not the foggest idea what are those keywords in it, and what to change to what.

I also suspect that maybe there is more than simply the mouse settings that Sax2 screwed up (auto detection - brrrrrrrr). I have an S3 Trio card, but so far as I remember it only worked well with the generic SVGA X server (and S3Virge driver). Now I happened to find somewhere that my system uses the XFree_S3 server.
I hounted down all X config tools to change it, but could not find a way to change that.

I have tried many tools and settings, but I am still helpless.

Texicle 03-27-2003 04:05 PM

Hmmm. The /etc/X11/XF86Config file won't do much for the focus, but it might help determine if your mouse is configured correctly (protocol, options, etc.).

What distribution (I am assuming SuSE as you mention Yast, but I'm not sure) and WM/DE are you using (KDE or Blackbox or what)? What kind of mouse do you have (brand, model, and type--PS2, serial, USB)?

Try opening up your /etc/X11/XF86Config file and posting the mouse parts of it here. However, it won't do us any good if we don't know the kind of mouse you've got.

Does your mouse move normally though? I know it doesn't click normally but is the motion correct? Hopefully we can get this sorted out.

J_Szucs 03-28-2003 01:54 AM

I use SuSe 7.3, with the KDE version that comes with it (I think KDE 2).
The mouse problem also concerns Blackbox.
My mouse is a Genius NetMouse Pro (the serial version of it).
Previously I used its basic functions with an other, generic mouse driver (I do not remember which one, and now Sax2 screwed it up).
The problem is:
- the mouse pointer movement is normal, but mostly the left mouse clicks activate controls that are not under the mouse pointer,
- while the left clicks do not activate the controls that are actually under the mouse pointer,
- and moving the mouse is often misinterpreted as a left mouse click.

Here are the relevant parts of my XF86Config file:
Section "ServerFlags"
Option "AllowMouseOpenFail"
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/ttyS0"
Option "InputFashion" "Mouse"
Option "Protocol" "Auto"
Option "Vendor" "GENIUS"

One more note: For month now, I have been experiencing a similar (but far less serious) problem with that mouse in windows, too. During those months I had no problem with that mouse in Linux, since I did not use its own driver there.

Texicle 03-28-2003 02:09 AM

How many buttons are on it? Sounds like you need to remap your buttons. I'm searching in google right now for modules and settings and whatnot.

Texicle 03-28-2003 02:22 AM

Try setting your

Option "Protocol" "auto"


Option "Protocol" "IntelliMouse"

as per which also states that you should have a third "magic button" which should be using the ZAxisMapping option. Make your section look like this:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/ttyS0"
Option "InputFashion" "Mouse"
Option "Protocol" "IntelliMouse"
Option "Vendor" "GENIUS"
Option "ZAxisMapping" "4 5"

and see how it works.

J_Szucs 03-28-2003 04:08 AM

Hi, Texicle

I tried the settings you suggested, but they did not help; no change in the misbehaviour of my mouse.

My mouse has the following buttons: LEFT CLICK, RIGHT CLICK, SCROLL, SCROLL LOCK.

Just a note: I do not insist on using its scroll functions, I would be happy if it could perform as a two-button mouse. Its users manual for windows says if its specific driver is not installed, it can perform as a two-button genius mouse with e.g.
Is there a generic two-button genius mouse driver in Linux, too?
What are the related settings in XF86Config?

Texicle 03-28-2003 02:58 PM

The link I provided has the information I found from the XFree86 people. It shows what to try out for the genius mousepro specifically. So you have a total of 4 buttons then? Try setting your zaxismapping accordingly:

Option "ZAxisMapping" "4 5 3 0"

I'm just guessing here, but if it makes ANY change in your mouse behavior, then we know we're making progress and can play around with the settings until we get it right. This may make matters worse, or it may make them better. I know I've seen some threads here at LQ that have to do with mice with multiple buttons but I can't recall each one. Do some searches and see what people have posted. I'll do the same and post back links I think might be helpful.

J_Szucs 03-28-2003 03:23 PM

Hi, Texicle

I must correct myself; your ZAxis tip improved the mouse behaviour a lot: now mouse movement is never interpreted as a LEFT CLICK.
As concerns the mouse focus problem, it is still there.

I think my mouse has 5 buttons: the SCROLL button seems to be one button from outside, but it covers two buttons inside: one for UP and one for DOWN scroll. (But I am not sure that it counts as two buttons).
What is the explanation of the numbers following the "ZAxisMapping" keyword on the option line? I need it to figure out the option line for the 5 button case.

I think - thanks to your help - we are very close to success.

I badly need some success, since last week I got some strikes from my machine: first one memory slot silently died, then my newer monitor did the same loudly, and now this mouse....
I could not do anything useful for a week.

Texicle 03-28-2003 05:08 PM

Add an option to your settings again:

Option "Buttons" "N"

where N is the number of buttons you have. I got this from the's XF86Config Options page. Hope this helps.:D

Texicle 03-28-2003 05:14 PM

Forget the ZAxisMapping option I told you to use: Try

Option "ZAxisMapping" "4 5"


Option "ZAxisMapping" "5 6"

I'm thinking the second will be better, but try them both.

J_Szucs 03-29-2003 02:39 AM

Hi, Texicle

I could finally find the solution:
Option "Protocol" "microsoft"
Option "ZAxisMapping" "5 6"
Option "Buttons" "2"
and now my mouse works correctly as a stupid microsoft mouse.
Naturally without the scroll functions, but that does not matter.

Thank you for your kind attention!

Texicle 03-30-2003 01:36 AM

I'm glad you at least got it working as a 2 button mouse. However, it should work with protocol set to IntelliMouse as well. If you set your buttons to 4 and leave the ZAxisMapping at 5 6 what does it do? This is out of sheer curiosity mind you.:D

J_Szucs 03-30-2003 02:01 PM

It did not matter whether I specified buttons 4 or 5 (with IntellyMouse protocol), the mouse behaviour was equally abnormal.
Only the 2-buttons config worked, which I only tried with the microsoft protocol. Maybe it would work with the IntelliMouse protocol, but I did not try that. I am happy as it is.

Maybe your tip should work, but there is something wrong with my mouse.
I suspect that as sometimes there are mouse focus problems in windows, too, which began some months ago.
I did not care much of that, since it is less serious there, besides I mainly use Linux, and windows is only used by my four-years old son to play games. However, he almost completely lost his moods in computer games (and computers) ever since the problem is there.
Now I am going to set up my mouse as a two-button mouse in windows, too.
It is faster than finding the reason for the problem (hidden hardware conflict?).

All times are GMT -5. The time now is 12:16 PM.