LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Strange Installation problem (https://www.linuxquestions.org/questions/linux-newbie-8/strange-installation-problem-272501/)

alirezan1 01-01-2005 03:41 AM

Strange Installation problem
 
Hello,

I have had MDK Linux 10.1 dual booted with XP pro on my computer. I have removed everything and tried to install everything again.
Now I get everything done with MDK 10.1 and as soon as it starts loading, it just shows "L" and freezes. I tried to install the boot loader on the partition and setting that partition to active but no luck.
Also, when I tried to install Red Hat 9.0 everything went on well but the same problem occured after the installation.
Now it gets messy when I try to install Fedora Core 3. I can NOT install FC 3 at all, with/without Windows XP on my PC. Not even when I removed every single partition on my hard disk to allow the FC 3 to partition it by itself.
It shows the following error:
"RAMDISK: Compressed image found at block 0
crc error
Kernel Panic - not syncing: VFS: unable to mount root fs on unknown-block (3,0)
"
However when I passed my own parameters to the kernel ( linux /boot=/dev/hda3 where the /boot of the previous linux was already there )
it did not work either.
I have absolutely no idea why this is happening to me.
Oh, by the way, when I tried to install vector linux, or any Live Linux ( on-cd ) it shows exact same error and stops booting.

Please tell me what to do.

Thanks

P.S.
I have One 120GB HDD set to primary ( hda ) .

mmmm 01-01-2005 02:03 PM

you should check RAM

alirezan1 01-01-2005 05:42 PM

Thanks for the reply.
What do you mean I should check the RAM? I really think it is fine, because I have absolutely no problem installing Windows and as I said Mandrake and Redhat. But in this case, when MDK and RHAT finish installing, they get stuck.
Do you think it is the problem with RAM?

Thanks

Alireza

comprookie2000 01-01-2005 05:53 PM

I would try another HD,I have had problems before using HD's that had windows on them from some venders,dell,gateway,compac they add a small partition at the begining (WARNING I AM NOT AN EXPERT) or the drive is out of sync somehow.and I try another drive and it works fine.Then I google around on how to compleatly wipe a drive and low format and then the drive is O.K.Try another drive you have around to see if it is that?

alirezan1 01-01-2005 06:15 PM

Well thank you very much for your reply. It is helpful indeed.
But the thing is I have my computer for about a year now ( more than a year actually) and I have had different OSs on it ( XP, 2000, 2003, Linux different versions ) and I always repartition my hdd before installing any OS. I don't think I have that partition you said, because none of the programs I use show that. Like I have partition magic and it does not show such a thing. XP partitioning program doesn't show that either. Linux FDISK doesn't show that either.
Well, do you think if I zero fill my entire HDD, will that work if this is the case? I have such a program that does this.

Thanks

comprookie2000 01-01-2005 06:24 PM

Try another HD just to make sure,install something easy like mepis[one disk] if it installs on that drive,then try your main drive,and go from there.

mmmm 01-04-2005 02:14 PM

You can check if any "linux on CD (floppy)" will boot itself.
Then try to mount linux partition, or check it (fsck.ext2)
Also you can try to boot your system from other lilo (from install CD).
If it works, i think, you will have to install other boot loader (grub).


All times are GMT -5. The time now is 09:40 AM.