LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Strange GDM Problem (https://www.linuxquestions.org/questions/linux-newbie-8/strange-gdm-problem-608509/)

asdf1122 12-22-2007 02:36 AM

Strange GDM Problem
 
I was trying to kill dormant connections on my box and accidentally killed the process id associated with my login. I lost my session and the screen went black with an animated mouse cursor. Now after reboot gdmgreeter is running but all I see is the same black screen with a mouse cursor. Does anyone know what could've been modified/state stored to prevent the system from loading properly even after a reboot? I have tried deleting the gdm state information in /home/$USER

It looks like all necessary processes are running:

Here is output from ps -ef | grep gdm:

root 2599 1 0 03:24 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 2668 2599 0 03:24 ? 00:00:00 /usr/sbin/gdm-binary -nodaemon
root 2672 2668 0 03:24 tty7 00:00:00 /usr/bin/X :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
gdm 2684 2668 98 03:24 ? 00:05:05 /usr/libexec/gdmgreeter --gtk-module=gail:atk-bridge:/usr/lib/gtk-2.0/modules/libkeymouselistener
gdm 2686 1 0 03:24 ? 00:00:00 /usr/libexec/at-spi-registryd
gdm 2688 1 0 03:24 ? 00:00:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=13
root 2829 2751 0 03:29 pts/0 00:00:00 grep gdm

I have tried clearing all the data from the /tmp directory in a futile attempt to get the box to get me to the gdm login screen. I have also tried uninstalling and re-installing gdm multiple time. X windows is loading fine. I get the graphical progress bar as services are being started up but when the time comes to get to the login screen... nothing... just blackness and a animated mouse cursor. Anyone have any ideas?

I am running Fedora Core 8.

Any help would be much appreciated.

AwesomeMachine 12-23-2007 05:55 PM

Reboot, kill everything to do with gdm and X, read /var/log/syslog | tail, or dmesg | tail, read /var/log/Xorg.0.log for clues. Reconfigure the X server if necessary.


All times are GMT -5. The time now is 12:02 PM.