-   Linux - Newbie (
-   -   Strange error in virtual consoles (

RoaCh Of DisCor 06-27-2005 08:02 PM

Strange error in virtual consoles

For whatever reason, whenever in a virtual console, I am flooded with the error:

hub 5-0:1.0: over-current change on port 2

It makes it hard to type this error keeps coming up. Any idea as to what this means, and how to fix it?


michaelk 06-27-2005 09:47 PM

I will throw out a guess. You have too many devices connected to the USB port 2 or a device is overloading the port. USB ports can only source 500ma of current for all devices connected. If one of the devices has an external power then you will need to use it or move a device to another port. Another solution would be to purchase a powered hub.

RoaCh Of DisCor 06-27-2005 10:09 PM

I actually took out all of my devices that were plugged into USB spots. Same problem. I'm on ubuntu right now..and have only had the problem on it.

michaelk 06-27-2005 10:27 PM

Could be a driver issue. Try removing the USB module (as root)
rmmod ehci-hcd

RoaCh Of DisCor 06-27-2005 11:20 PM

Do you think a kernel recompile could do the trick?


Okay odd, that fixed it! I need to do something to fix this permanantly?

michaelk 06-28-2005 07:19 AM

After some searching:
According to the kernel changelogs the VIA controllers over-current status bit is inverted with respect to the Intel controllers. Do you know what kernel ubuntu is using?

So it appears that a kernel patch is in order.

RoaCh Of DisCor 06-28-2005 03:23 PM

Well...the ubuntu kernel was a 2.6 version I believe. Last night I installed slackware on a seperate partition to do some testing. I updated the kernel to Oddly enough, I still get the error..but on slackware, I only get it when I restart or shutdown. Everything is functional on...but I do still get the error. Atleast it doesn't flood virtual consoles all the time. I don't remember getting that error any time before...even on a 2.4 I'm a bit confused :(

mentok 12-09-2005 09:21 PM

I've been having the same problem with "over-current..." messages popping up. I'm using kubuntu with kernel 2.6.12-9-386 on an old HP Pavillion. I rebooted, went into the BIOS setup and changed the option "USB Legacy Support" from "Auto" to "Disabled" and I am not getting those messages anymore. Hope this helps someone.

:confused: :study: :D

All times are GMT -5. The time now is 04:10 PM.