LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   strange display in Gimp and package manager (https://www.linuxquestions.org/questions/linux-newbie-8/strange-display-in-gimp-and-package-manager-52342/)

romcgill 03-29-2003 08:27 AM

strange display in Gimp and package manager
 
Ever since I first tried to use The Gimp I have been frustrated. Mandrake 9.0, dual boot with Win 95.

The various Windows load okay but the words are made of symbols consisting of lines of various shapes and thickness etc. so unreadable. Anyone any ideas of what this could be.

I tried reinstalling the packages from CD but no change.

It is not a huge issue as am hoping to buy Mandrake 9.1 soon, but just curious about it and possible causes and solutions.

Thanks
Rose

mhearn 03-29-2003 11:17 AM

You'll have to be more specific, but this sounds like a font issue. Fonts are much better in the latest Linux distros, Redhat 8 licked them first, I think MDK 9.1 should improve them as well.

romcgill 03-29-2003 02:09 PM

Hmm - well as best as I can describe is this.

The Gimp windows load is one which says "The Gimp", then underneath has four menus - F, followed by three symbols - presumably for file
X and then H and three symbols, presumably for help.

The drop down menus for each of these are the same - a word with a readable capital followed by unreadable symbols.

Underneath this top menu, in this particular window are twenty boxes with signs on them. When the mouse hovers over each more symbols appear - which I assume name what the button is for. Fonts issues does make sense.

Will try get a copy of Mandrake 9.1 to try soon I think.

Can I download or install the fonts from anywhere? I have whole lists of fonts in my install files on the computer.



Thanks
Rose

mhearn 03-29-2003 02:12 PM

Oh ok, I just assumed you'd encountered the hinting suckage that plagued Linux until about 6-7 months ago, but this sounds different.

Which version of the gimp is this? It does indeed sound like a serious font problem.... it's just that in GTK2 (ie an unreleased version of the gimp) boxes with signs in means unprintable character, usually foreignm, but i doubt you are using the unstable 1.3.x series

romcgill 03-29-2003 02:28 PM

It is version 1.2.3-17mdk.

It is possible I have inadvertently done something in my forays as Administrator as I am very new to Linux from Windows. So, using the command line is quite daunting. So far as I know I haven't done anything at all to the Gimp except try to use it, but I guess anything is possible. Though it has always looked like that from the first time ever I looked at it.

I have the CDs here and have a spare second hard drive which is currently empty. Thought about installing to that and seeing if there's any difference, but am scared of the bootloader as lost access to Windows using Grub when installing RedHat some weeks ago. I'm told the Lilo will just do it automatically and everything will be okay, but remain wary. I enjoy using the machine and would hate not to be able to access the net and email etc.

Cheers
Rose

mhearn 03-29-2003 02:39 PM

Can you get a screenshot of what you're seeing? If you can upload it somewhere great, if not email it to me:

mike@remove-this-part-theoretic.com

obviously, delete the spam armouring first.

lilo/grub removing access to windows is a different issue entirely, rare but not unheard of. Let's focus on the fonts first

romcgill 03-29-2003 07:47 PM

Sorry to appear stupid - but how does one get a screen shot?

I tried to select to cut and paste but nothing happened.

Okay I see a thing called Screenshot or something - will have a go with that.
Cheers
Rose

romcgill 03-29-2003 08:12 PM

Tried twice. Seemed to get the screenshot okay - it shows as a file anyway - but mail was returned as not being able to find "remove-this-part-theoretic".

Where else could I upload it to?
Taa
Rose

mhearn 03-30-2003 08:15 AM

Well, you were supposed to delete the part of the address "remove-this-part", to leave mike@theoretic.com which is my actual address :) You'll find people sometimes apply spam armouring like that, but as I already get flooded anyway I guess one more hit won't make much difference.

So, just email the screen to mike@theoretic.com :)

romcgill 03-30-2003 05:03 PM

Oh!!!

I really am displaying my ignorance aren't I.:)

mhearn 03-31-2003 01:58 PM

Nah, it's OK, we all learn these things somewhere.

I passed that screenshot along to a few people (who write software using gtk) and none of them had ever seen anything like it. Hongli suggested checking your language settings, but that's a rather grasping at straws imho.

Can you remember what happened to make things appear that way, or was it like that from the start?

romcgill 03-31-2003 07:50 PM

It was always like that. But a curious thing is that in Gnome (that was KDE) it displays okay, but only one window loads.

I also get that kind of display now in Software Package Manager, but that is something I did somehow I think.

I was trying to configure it after reading an online tutorial. I tried to close it and log off as it was late and I wanted to go to bed. It simply wouldn't close - waited twenty minutes or so.

Didn't want to do anything silly because was in root, but eventiully closed internet connection and then was able to shut everything off and log out. Next time I logged the display in Software Package manger was the same as the Gimp!

The install was done by a work colleague via ftp on his work set up and the Package Manager was never configured correctly and had trouble installing stuff because of it. Hoping to get Mandrake 9.1 soon and have a go with that.
Did wonder about doing a completely new install from the CDs as I now have a CDROM that should read them, but scared about the bootloader overwriting things and not being able to access anything. Though Lilo doesn't seem to have the reputation for doing that. It happened to me with RedHat and Grub.

BTW - where is Malvern? I lived in England for a year almost, way back in 73-74 - Stoke mandevilee Hosp, Bournemouth and London.
Thanks
Rose

mhearn 04-01-2003 12:47 PM

Sounds like file corruption to be honest I suppose. Weird that it only happens in KDE though. In GNOME, are you sure you can't just open the dialogs from the dialogs menu? they don't necessarily appear immediately.

Malvern is on the Welsh border, in the south west, near Worcester or Birmingham. Fairly quiet here :)

romcgill 04-01-2003 03:00 PM

I'll have another look in Gnome then. I tend not to use Gnome because internet connection times out after twenty seconds and I'm too lazy to find out how to correct it!! Have looked in Preferences with no luck.

Went to Wales but not Birmingham or Worcester. Zoomed up a motorway past Birmingham once!

Cheers
Rose

mhearn 04-01-2003 03:40 PM

Your setup sounds seriously messed up :) No consolation I'm sure, but it shouldn't be doing a lot of these things.

I'd suggest just installing the latest redhat or mandrake fresh.


All times are GMT -5. The time now is 04:51 PM.