LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Strange behavior when running konqueror as root... (https://www.linuxquestions.org/questions/linux-newbie-8/strange-behavior-when-running-konqueror-as-root-77342/)

atreid 07-30-2003 11:53 AM

Strange behavior when running konqueror as root...
 
Hi...

I'm pretty new to linux, installed RedHat 9, then Slackware, then Lindows, then Mandrake, and then back at Redhat 9, all that less than a week ago... Now I'm really running RedHat 9, and it looks like I'm going to stick with it for some time...
Worked 10 years as computer tech (in windows) before...

Everything is sooo nice... except...

I can't run konqueror as root... When I do, the konqueror window pops up, then disappears! I tried running the icon placed in the redhat menu to run it "as a superuser", I tried to : su then type: konqueror, and same thing happens, the window pops up, then closes automatically and I get back in console...

kdesu konqueror does the same thing!

I tried kdesu other things like xine, gmplayer or nautilus (eurk!), and they all work...

The only workaround I got was to do: su - then: konqueror

The console then prints: mcop warning: user defined signal handler found for SIG_PIPE, overriding

But the Konqueror window stays opened... at least...

So I could create a Link that exucutes the command: konqueror
and configure it to open a terminal window, and use it as the user "-",
but it's a cheap workaround...

But it makes me wonder because I know I should be able to use the "...as a superuser" icon, or to use kdesu konqueror... is that a known bug somehow?

Thanks for any replies...

Alex

p.s. just don't tell me to use that semi-windows-like ugly nautilus :tisk: :p


All times are GMT -5. The time now is 11:49 PM.