LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2019, 10:40 PM   #1
giancarlo64
Member
 
Registered: Jul 2018
Location: Switzerland
Distribution: debian
Posts: 33

Rep: Reputation: Disabled
Strange accent behaviour


Hi,
I use a Swiss-German keyboard
since some days I have a strange behaviour using accents. If to compose an accented letter I use the "accent key" + the letter I get before the accent and after the letter instead of getting the accent over it. Example: Instead of ù I get `u.
If I use the already accented key it work but for some letters I need to generate it with the accent key (example ù).
Why this?

Regards

Gian Carlo
 
Old 01-15-2019, 01:43 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,533
Blog Entries: 9

Rep: Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393
Quote:
Originally Posted by giancarlo64 View Post
since some days
what changed between now and then?
 
Old 01-15-2019, 04:36 AM   #3
giancarlo64
Member
 
Registered: Jul 2018
Location: Switzerland
Distribution: debian
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
what changed between now and then?
It is difficult now to remember but the last programs that I have installed are:
latex with TeXstudio
skype
Windows in VM is running ok

Gian Carlo
 
Old 01-15-2019, 10:46 AM   #4
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Xubuntu
Posts: 5,322

Rep: Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825
What is the output from this command?
Code:
setxkbmap -print
 
Old 01-15-2019, 12:40 PM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 12,533
Blog Entries: 9

Rep: Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393Reputation: 3393
Quote:
Originally Posted by giancarlo64 View Post
latex with TeXstudio
this probably included some fonts installation.
could it be a font issue?
 
1 members found this post helpful.
Old 01-15-2019, 03:18 PM   #6
giancarlo64
Member
 
Registered: Jul 2018
Location: Switzerland
Distribution: debian
Posts: 33

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by DavidMcCann View Post
What is the output from this command?
Code:
setxkbmap -print
Hi David
the output is

xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+ch(de_nodeadkeys)+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc105)" };
};

Gian Carlo
 
Old 01-16-2019, 10:55 AM   #7
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Xubuntu
Posts: 5,322

Rep: Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825
There's the problem! You have the "nodeadkeys" version of the Swiss-German (ch) driver, so the keystrokes that should give you dead_acute, dead_grave, and so on, are giving you acute, grave, circumflex instead. Run your keyboard configuration tool and install the standard Swiss-German driver, then uninstall the no-dead-keys variant.
 
1 members found this post helpful.
Old 01-17-2019, 05:13 AM   #8
giancarlo64
Member
 
Registered: Jul 2018
Location: Switzerland
Distribution: debian
Posts: 33

Original Poster
Rep: Reputation: Disabled
Hi David,
thanks! Strange that the keyboard configuration has changed...

Regards

Gian Carlo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Latex doesn't accept one accent on one word but accepts the same accent on othe words xpucto Linux - Newbie 3 12-05-2012 01:28 AM
convert accent... os2 Programming 1 03-04-2005 09:03 AM
printing Spanish accent characters in Perl/tk entry widget puedo Programming 1 02-19-2005 01:16 PM
FC3 font problems - accent display - renaming error tomhemba Fedora 8 01-17-2005 02:33 PM
Question about accent characters, etc in Openoffice.org LaptopLinux Linux - Software 1 07-25-2004 09:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration