LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Still can't get ADSL modem to work (https://www.linuxquestions.org/questions/linux-newbie-8/still-cant-get-adsl-modem-to-work-278169/)

Nizhni 01-15-2005 03:19 PM

Still can't get ADSL modem to work
 
I have just re-installed the ECI ADSL driver for my Voyager 105 modem on Suse 9.2, in an attempt to get the synch .bin right. But I still haven't got online and I've had these error messages:

First:
no synch .bin file found in /etc/eciadsl or subdirectories
Please check your driver installation!

Then, on entering "./eciadsl-start | tee log.txt" at root:
./eciadsl-start: No such file or directory

On entering "!/eciadsl-start | tee log.txt" at root:
!/eciadsl-start: event not found

Can any kind soul tell me what I've done wrong or how I can put it right?

I thought I was reasonably computer-literate, although no professional at it, but I'm beginning to feel baffled by this whole thing. Help!!!!!!!

Tom

egag 01-15-2005 03:37 PM

well...read the first 3-4 links onhere :

http://www.google.com/search?q=Voyager+105+linux

it doesn't look very promising.......
( can't you get your hands on a adsl modem/router or so .... )

egag

Nizhni 01-15-2005 04:27 PM

I've noticed that an awful lot of other people have this sort of trouble and I was already toying with the idea of doing it another way. But I don't know anything about LAN networks, routers etc.

Do you need just one piece of equipment for it?

How much does it cost, compared to a modem?

Is it easy to instal and reliable?

How does it connect with the ISP - down the same phone line as a modem, or what?

If it goes some other way, wouldn't I have to change to another ISP which offers that service?

Maybe these look like naive questions. But if I do give up on the modem I want to be going to something that is sure to work.

Cheers,
Tom

egag 01-15-2005 04:43 PM

well..i've got a modem/router ( adsl ) ; one side connected to the phone-line ,
the other side connected to an ethernet-connection
( my eth is on the mobo, but you can also use a card )

also that router has 4 eth outlets, to connect more pc's.
it's just a small dhcp-server. it has to be setup with your login-info ( check with your ISP )

anyway, it's simple to setup, and prices ???
my guess at this time : 20 $ for the router/modem and if needed an eth-card for 10$ ( or below )

egag

Nizhni 01-16-2005 03:15 AM

Sounds good - and thanks for all the advice.

How does your router connect to the computer? Not via a USB, I imagine?

Tom

bornhj 01-16-2005 03:28 AM

Via an Ethernet cable, usually blue. If you really want to, you can make your own cables. Google 'ethernet cable crimping' or the like.

The plugs on an Ethernet cable are nearly the same as telephone (RJ-45?) plugs (at least in Australia), except wider.

Another benefit (you may call it an annoyance) is that the router will act as a basic firewall, only routing certain ports through to the LAN, and dropping the rest. This means, however, that if you want to let an outside computer connect to yours on a different port, you need to explicitly route that port to your PC. For example, I was setting up Remote Desktop on one of my PCs. It uses port 3389. So I had to login to my router (via the browser-based management, standard on almost all routers) and tell it to forward all traffic on public port 3389 to port 3389 on my PC (10.1.1.4).

Nizhni 01-16-2005 03:49 AM

As I understood it from Egag, the cable plugs into the telephone network at one end just like a modem (or a telephone or fax). But what kind of port does it plug into in the computer? A USB port or what?

Tom

egag 01-16-2005 06:23 AM

that' where the ethernet-connector comes in.
usb is also possible but eth. is much simpler to setup.

egag

bornhj 01-17-2005 12:49 AM

This is a very basic setup.

Code:

                        INTERNET
                          _|_
                          |_| <-- Phone Jack
                            |
                            | <-- Phone Line
                            |
                        ____|____
                      |        |
                      | ROUTER  |
                      |_________|
                            |\____Ethernet Jack (usually 4 of these)
                            |<-- Phone Line 
                            | Ethernet Card (possibly inbuilt on motherboard)
                        ___|/__
                        |        |
                        |  PC  |
                        |_______|

I apologise for my awful ASCII drawing. Basically You connect the modem to a phone jack, just like the one you put a phone in, and the other end of that cord into the router (it has one ports different from the rest, this is for the phone line). On the other side, one end of the Ethernet cable goes into one of (usually) 4 ports on the router, and the other end goes into a "Network Interface Card" (usually abbreviated to NIC) in a PCI slot in your PC. Sometimes this NIC is built into your motherboard and therefore the cable can just go straight into the appropriate connector.

Like I said earlier, this is a much better setup for the purposes of protection.

Let me know if you need any more help.

RynoFly 01-17-2005 01:14 AM

i just noticed one little problem with your drawing.
the cable going from your router to your ethernet card is ethernet cable not "phone line"
Also some routers have firewalls. not all have one you can buy one without it. you don't find many modem/router combos out there esp for $10. Usually what you do is you buy a router (linksys D-link are some popular brands) You set it up like this:

1)phone jack in wall
------phone wire
2)Modem
------ethernet cable(usually blue) plugged into the ethernet port labled "uplink" or something similar in back of router
3)Router
------ethernet cable plugged into one of empty ports in back of router(not the uplink, thats for your modem)
4) your computer(via a network interface card) basicly a pci card witha ethernet port and 2 blinking lights for activity. again sometimes this is on your mother board

sorry i don;t know how to do the fancy pictures ;)

Nizhni 01-17-2005 02:14 PM

Thanks for all the advice, folks.

Okay, I've gone out and bought an ethernet router (which cost more than the operating system...) but I can't get it to work either. All the manuals tell me different things I ought or ought not to set up for it, while some other postings on this forum have said you don't really need to set anything up at all.

Now I'm completely confused. Following what seemed to be authoritative advice, I changed some of the settings to what appeared to be correct. Maybe I should have left well alone?

On the Suse/Novell forum on this site I have requested advice on configuring DHCP, but I'm no longer sure that's what I need. But I don't know where else to begin.

Anyone got any advice how I can begin to unscramble the situation?!

Tom

egag 01-17-2005 04:17 PM

well...how far are you.....
- do you have it all hooked up....eth. connection to pc......adsl conn. to phone-line.

- do you have a router/modem combo.? ( what's the type.. )

- i think as a start, you have to give the modem the login-info to connect to your ISP.
and to do that, you must connect by eth. conn.

egag

Nizhni 01-17-2005 04:48 PM

I've bought a Netgear DG632, which seems to be from Texas Instruments. I tried configuring the computer as the instructions told me - but they told me to configure different things in different ways. Hence the present muddle. ("They" are the router's instructions and manual, the Suse Linux manual and a Teach Yourself book on Linux.) A couple of people on other web forums gave me advice on how to un-muddle it, but it still hasn't got me connected.

I'm beginning to wonder if I'll have to uninstal Linux and start all over again. I hope it doesn't come to that. God only knows how many hours this has all taken me, if I include all the troubles I had with a hard disk breakdown and an apparently faulty Windows reload by the manufacturer (or was it a virus?) before this...

Cheers,
Tom

egag 01-17-2005 05:42 PM

that modem has got good references.
i read : " installs itself...; very easy...; ...etc "

i think first you must setup the eth. conn. to your modem.
check with " # ifconfig " if you see an eth0 interface....
if so , try to ping your modem ( make sure it has power ) like " ping. <ip-adress-of-router/modem> "

does that work...?

egag

Nizhni 01-17-2005 06:26 PM

Good references: well, the box looked convincing as I had to pay twenty pounds more for it than two others that were on offer. It has a well organised and comprehensive manual on a CD, which you can download in pdf format.

# ifconfig showed this:

eth0 Link encap:Ethernet HWaddr 00.C0.9F.35.5B:BF
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:fe35:5bbf/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:35 errors:0 dropped:0 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:1000
RX bytes:7710 (7.5 Kb) TX bytes:6602 (6.4 Kb)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:50 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:0
RX bytes:3260 (3.1 Kb) TX bytes:3260 (3.1 Kb)

# ping. <ip-adress-of-router/modem> showed this:

bash: syntax error near unexpected token 'newline'


By the way, I can get into the router with the 192.168.0.1 entry on the browser now. However, I didn't complete that task as I thought I'd made a mistake and I couldn't see how to backtrack to correct it. But now when I try to get back in and I put in my passwords, it says "Authentication failed". Do you know if there's anything I can do about that? Or is there another way round it?

Still, the fact I've got that far shows that I've made big progress since my rather bleak assessment earlier. It's great to have all this help around just when you need it most!

Cheers,
Tom


All times are GMT -5. The time now is 11:10 PM.