-   Linux - Newbie (
-   -   startx won't display (

bfbf504 05-30-2004 09:27 PM

startx won't display
I've tried two Redhat installs this weekend on two different machines, and I get the same error when I try "startx"
Fatal server error:
no screens found

I've been trying all weekend and I can't figure out what to do. From the reading and research I've conducted so far it looks like this error has something to do with the video card which would make sence b/c during the install neither my video card or display was listed in the Redhat install selection.

By the way I'm installing Redhat 8 as a virtual machine using Vmware Workstation 3.1

First I tried to install Redhat 8 on my laptop, a Dell Latitude 600C. According to the Device Manager, my display adaptor (video card I guess) is a Mobility M3, by ATI. The monitor is, well it's a laptop so I don't know what that would be.

Well I was having so much trouble I decided to do the install on my desktop, HP Pavilion 6746C, which according to the Device Manager, has a Intel Corporation 810 Graphics Controler Hub display adaptor. I just bought a flatscreen monitor which is a MAG 765.

I'm a Linux Newbie and I don't know what to do.

Detail of error message:
XFree86 Version 4.2.0 (Red Hat Linux: release 4.2.0-72 / X window System (protocol Version 11, revision 0, vendor release 6600
Release date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date , look for a newer version before
reporting problems.
Build operating sytem: linux 2.4.18-11smp i686 [ELF]
Builf Host:

Module loader present
OS Kernel: Linux version 2.4.18-14 ( (gcc version 3.2 20020903 (Redhat Linux 8.0 3.2-7))
Markers: (--) probed, (**) from config file, (==) default settings,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not inplemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log",
(==) Using config file: "/etc/X11/XFConfig"
(EE) No devices detected.

Falal server error:
no screens found

X10: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known proccessed) with 0 events remaining.

shane25119 05-31-2004 12:58 AM

what you're going to want to do is start up that laptop and type in the command lynx if that doesn't work then links

go to ati's website and download the driver for your video card. i would recomend actually having this open on your other computer so you can read the documentation easier. it should spell out exactly how to install the video driver and update your XFConfig


bfbf504 05-31-2004 09:08 PM

Is your suggestion that I use the lynx command to opening sort of browser and point it to ATI to get the updates?

Sounds good buy I don't have the internet configured on the OS. This is the main reason I'm trying to run startx to configure the internet.

Unless someone can tell me how to configure my wireless internet connection via command line

EnigmaX 05-31-2004 11:00 PM

Generally, that means that it could not found a screen that fit your monitor. You could try editing the file manually, or run /usr/X11/xf86config to do the configuration for you with some information.

malekmustaq 06-10-2009 02:13 PM


It is difficult to judge accurately what is to be done from the current point of view as you are running redhat over windows vm on an old machine. There are more things to consider. Why not install redhat on a separate partition? This manner you can deal with the screen and wireless issues face to face. If you have say three or four gigs of space available that would be more than sufficient to host a linux. Use your windows partitioning app or the redhat installer to partition the space.

chrism01 06-10-2009 09:14 PM


OS Kernel: Linux version 2.4.18-14 ( (gcc version 3.2 20020903 (Redhat Linux 8.0 3.2-7))
That really is RH8 (Psyche) which hasn't been supported/updated in years!:

Don't even bother trying. Get either the latest RH Fedora (v10 or 11) or Centos 5.3 (free ver of RH Enterprise Linux)

All times are GMT -5. The time now is 12:22 PM.