-   Linux - Newbie (
-   -   Startx results in a black screen with VGA and screen errors (

kwosource 03-09-2005 02:08 AM

Startx results in a black screen with VGA and screen errors
My problem is that I have a Pentium MMX 200 Mhz, 128 MB RAM, SCSI, 4 GB + 8 GB hard drives, Vision VGA monitor which can handle 1024x768 and Phoenix S3 Vision868 graphics card with 2mb RAM.

Because of my limited resources, I have been playing aroound with a number of linux distros in order to find one that will not run to slowly on my system.

So far I have only been able to get Suse x9 personal running, after receiving advice from the forum. Under Suse my monitor is unknown and my video card is recognised as a VESA framebuffer vesa card. I am able to get 640x480 resolution with 16 bit colour depth.

Slackware 8.1, 9.1; Read Hat 7.3, gives my VGA and screen errors when running startx. The installation process goes alright. This occurs even when choosing the standard VGA monitor settings (1) and either VGA compatible, VESA compatible, S3 868 (generic), S3 Vision868 (generic) settings when configuring xf86config.

I tried an old version of Res Hat (6.1) which also installed and ran immediately in graphics mode (GNOME or KDE) without any tweaking.

Suse is alright, just runs very slowly on my limited hardware resources.

Any advice, pointers APPRECIATED.

mcd 03-09-2005 07:09 PM

that sounds very strange...i've gotten slackware running on several old computers just fine. right now i've got slack 10.0 on an old PII 200 mH compaq with 56MB RAM. i used 3 different monitors that i rescued from various dumpsters/friends, and never had any errors with the standard VESA settings. i would suggest that slackware is a great distro to run on an old machine, and that people in the slackware forum should be able to help you sort out any errors you get. i know you already tried it, but that's my advice.

kwosource 03-11-2005 03:27 AM

I tried again last night. Slackware 8.1, 9.1, Red Hat 7.3 - the same thing. Startx gives the same error.

I tried some light weight distributions. Both Dambsmalllinux and Featherlinux runs without any problems. Both off the live-CD as well as when installed to the hard drive. One thing - with both dambsmalllinux and feather, i do get an error concerning an incorrect screen mode and the option either to choose a mode manually from a provided list, or to either press <SPACE> or wait 30 seconds to continue. I either press <SPACE> or wait 30 seconds. The dambsmall and feather systems then run and load without a problem.

I really do not know.

mcd 03-11-2005 02:52 PM

well, i don't know what's going on. please post the exact errors you get when you try startx, as well as the relevant section of your xf86 config file.

noteventime 03-11-2005 02:58 PM

I would try ArchLinux, u need to do some work by yourself but the documentation on the website is quite good. You get to chose to use XFree86 or Xorg and chose your windows manager, where you could use a more lightwave one.

All times are GMT -5. The time now is 04:32 PM.