-   Linux - Newbie (
-   -   Starting X remotely (

Intacto 11-25-2005 09:01 PM

Starting X remotely
Ok I have a very simple question:

I was running FC4 over VNC and my user session had to be logged out. Now I set it to power back up automatically, but since it is stuck at the login screen, the only thing I can really do is to use SSH to perform CLI logins. I was wondering if there is a way to start the x server to get back to my gnome desktop over a PuTTY SSH connection from Windows XP?


spooon 11-26-2005 05:46 AM

There is X forwarding in SSH; but that requires an X server, and it doesn't let you use a "desktop" kind of thing. So it's not what you're looking for. Shoudn't there be a way to configure the VNC server so that you don't need to be logged in and it can start a new session?

dubya 11-26-2005 12:22 PM

I just recently did something like this. I'm pretty new at it so I'm not well educated on how it all works, but under preferences in the desktop menu, there's a setting called remote desktop. You may need to change some of these settings.

For me, I had to connect remotely using port 5801 and then when the pop-up appeared with the ip, port, and display number, I entered '0'. This also means that I had to open port 5801 in addition on my system and in my router.

This is all accessed with a desktop already running. Just something you might want to try.

ziggie216 11-28-2005 11:00 PM

so do I enter in this? ip:5801:0

dubya 11-28-2005 11:36 PM

This is what I use:


If VNC is set up correctly and are using RealVNC, you'll get a pop-up with http://ip:5801:0 in it. Change the last zero to a one and you're off.

Don't forget to start a VNC server on display 1 with the following command:

$ vncserver :1
Good luck. Post back if you have more problems.

All times are GMT -5. The time now is 04:38 PM.