-   Linux - Newbie (
-   -   Starting services (

tstuart 09-07-2006 08:21 AM

Starting services
I'm trying to get openswan to work. My next step says to run "service ipsec start"
When I try this I get:
service: command not found

I am doing this as root. I went to root doing su -
I also did a whereis service and it could not find it. This is normally located in sbin from what I've been reading. Is there something I need to install? I'm running Kubuntu...



tstuart 09-07-2006 08:30 AM

In addition to what I've already put in I just checked and initscripts is installed, but for some reason doesn't contian /sbin/service

zulfilee 09-07-2006 08:40 AM

I dont know about Kubuntu but services can also be started this way

/etc/init.d/servicename start

So for you it will be

/etc/init.d/ipsec start

And /sbin/service comes as a part of initscripts package.
So you can check if the package is installed in your PC.

michaelk 09-07-2006 08:51 AM

service is not included in all distributions. kubuntu is based on debian which does not use the service command.

Use instead:
/etc/init.d/ipsec start

tstuart 09-07-2006 08:59 AM

that's excatly what I needed! Thanks for all your help!

sseeker 09-07-2006 09:05 AM

What distro do you use?
Red Hat you just go
Applications > System Settings > Services > httpd > Start


All times are GMT -5. The time now is 05:59 AM.