-   Linux - Newbie (
-   -   Start button on K3b greyed out (

cogprofessor 06-18-2011 04:28 PM

Start button on K3b greyed out
I'm trying to burn the .ido of Mepis 11 to a DVD. I have a 4.7Gb DVD-R in the drive. Usually, I would just navigate to the .iso and select it, and K3b would do the rest. Now, when I do that, K3b does check the md5sum, and it's correct, but then it just sits there with the Start button greyed out. I see others on this forum have had that problem, but I couldn't find a solution. Any ideas? Thanks.

PTrenholme 06-18-2011 07:36 PM

May we assume that you've checked the obvious: the the disk you have in the drive is, in fact, blank as writable?

The only reason that the "burn" option would be disabled is that the disk in the drive cannot be written to by you. Beside the obvious reason, you may not be the one of the groups having permission to write to /dev/sr0. Specifically, are yu a member of the cdrom, disk, wheel, or adm groups? (Do a ls -l /dev/sr0 to see which group is permitted to write to that device. The group ownership depends on how your distribution is set up.)

cogprofessor 06-18-2011 11:39 PM

As far as I can tell, the disk was OK. It was brand new. Thanks for the advice on checking the group membership. I may have found a solution by burning the disk at home on my laptop. That worked (almost). That is, k3b DID burn the .iso to the DVD. But just before it finished (with only 20 sec left ) I got an error message "Section 1 not the same as the original. Nevertheless, the Live CD works well enough that I'm running it right now on my laptop. However, I'm not about to try to install from it under these circumstances. So, tomorrow morning, I'll go back in to the office, get another DVD (they're at my office, not at home) and I'll try the burn again, first with the laptop. Then if I get that error message again I'll have to try another course of action (I can check that group membership - or maybe download the .iso again, although I don't think that's the problem because the md5sum was correct). Anyway, that's it for tonight. Thanks for the help.

salasi 06-19-2011 03:39 PM


Originally Posted by cogprofessor (Post 4389565)
Usually, I would just navigate to the .iso and select it, and K3b would do the rest...but then it just sits there with the Start button greyed out.

I believe that the meaning of the 'k3b button greyed out' is 'I know that you might like to do that, but I can't let you do that (with current settings), Dave'. Obvious things that come to mind are:
  • too much data to fit into the space available (which could happen with too much data for a DVD (which, taking into account formatting, is about 4.3 G rather than the 4.7 G that you might expect) or it could happen with the size of the DVD being under-reported)
  • formatting of the disk has marked bad blocks, that has decreased the capacity of the disk and it no longer has room to store the data selected
  • the drive can only write CDs, and therefore the limit is the limit of a CD rather than a DVD
  • the selected write speed is incompatible with the drive's stated capabilities
  • the selected write speed is incompatible with the disks stated capabilities
  • the disk itself does not seem to be writable
  • there is no speed which is compatible with both the disk and the drive (eg, the disk is 1x - 2x, but the drive is 4x to 6x)

(another possibility, albeit what should be a more remote one, is that a bug in the driver firmware (or k3b, or the support programs) has reported the drive capabilities in a way that has been misunderstood and consequently something like the last of those possibilities has been triggered, even though that should not have happened - the same thing could happen with the disk itself, of course)

It should be possible by poking around in k3b to get more of a clue which of the above applies. Be aware that I have also seen evidence that there can be mysterious incompatibilities between k3b and the underlying utilities, so if you have the option of swapping, say, CDWrite for something else, that can be worth a try.

cogprofessor 06-19-2011 06:47 PM

I solved the problem by slowing down the burn speed of my DVD burner. Thanks to all.

All times are GMT -5. The time now is 10:41 AM.