-   Linux - Newbie (
-   -   SSI and appache (

jax8 03-23-2004 02:24 AM

SSI and appache
How do you get SSI working on Apache

I am using something like this

<!--#include virtual="/footer.shtml" -->

and am accessing it from localhost but the include will not work

I am using Fedore Core 1 and the default Apache settings from the installation CD

Kovacs 03-23-2004 03:15 AM

Are you getting any error messages? I have no idea what the default httpd.conf is with FC but you might need to enable parsing pages for SSI. You might need to add or uncomment these lines in httpd.conf:

AddType text/html .shtml
AddHandler server-parsed .shtml

And make sure that under the options for document root, you have includes enabled, something like this:

Options Indexes FollowSymLinks Includes

All times are GMT -5. The time now is 09:10 PM.