Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-04-2009, 10:56 AM   #1
LQ Newbie
Registered: Jun 2009
Posts: 14

Rep: Reputation: 0
ssh to redhat from solaris without passwd

Hello everyone,

I am trying to ssh to a Redhat server from a Solaris 10 without password.
I have generated the keys on my Solaris box and copied to the Redhat box in .ssh/authorized_keys but it still asks for the password while login.

Pls help.

Old 09-04-2009, 11:00 AM   #2
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
in .ssh/authorized_keys but it still asks for the password while login.
When you generate the keys don't assign any passphrase. When it ask's for the passphrase, just press the enter key. Copy the keys as you have done earlier.


Old 09-04-2009, 11:42 AM   #3
LQ Newbie
Registered: Jun 2009
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks Prashant but thats what I had done, I had pressed enter when it asked for parphrase and copied to the destination server. But that has not worked for me.

Old 09-04-2009, 02:08 PM   #4
LQ Newbie
Registered: Sep 2009
Posts: 20

Rep: Reputation: 1
So on the Solaris Server you want to do the following


usually the default storage location for the keys are fine. In this case /root/.ssh/id_rsa

Leave the passphrases blank

Now move the public key to the Red Hat machine

scp /root/.ssh/ root@<ip address>:~/.ssh/

Now jump on the Red Hat machine and load the keys in.

cd /root/.ssh/
cat >> authorized_keys

Now get back on the solaris machine and try to ssh into the redhat machine

ssh root@<ip_address>


Hope this helps
Old 09-29-2009, 01:43 PM   #5
LQ Newbie
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0

make sure that your permissions are set properly
chmod 700 ~/.ssh
chmod 600 ~/.ssh/*

ssh enforces that the source host(private) and destination host(public) keys are accessible only by the owner.
Old 09-29-2009, 09:27 PM   #6
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Check the /etc/ssh/sshd_config settings on the target; most people disallow root to login via ssh for security reasons. Also check it expects to use keys and not passwd.
Old 09-30-2009, 12:01 AM   #7
Registered: Sep 2009
Posts: 196

Rep: Reputation: 38

Last edited by Smartpatrol; 03-11-2010 at 10:37 PM.
Old 09-30-2009, 01:17 AM   #8
Senior Member
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You need to disable the authentication via password in sshd.conf file.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
su passwd when using SSH key file foampile Linux - Newbie 2 04-23-2009 04:58 PM
ssh for not asking passwd linuxguy08 Linux - Server 13 09-04-2008 12:58 AM
ssh without passwd abd_bela Debian 4 06-23-2008 03:55 PM
ssh and passwd asked fjaspart Linux - Networking 3 06-22-2007 03:16 AM
can i change my passwd and login to ssh? pippet Linux - Newbie 1 10-27-2004 02:41 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration