LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-15-2017, 12:02 PM   #1
justsaucerawsauce
LQ Newbie
 
Registered: Nov 2017
Posts: 12

Rep: Reputation: Disabled
SSH not working (Debian)


I just recently installed Debian 9.2.1 with an SSH server (No GUI)
But when I log in SSH via Putty, I get this weird message

"login as: nodrinks

****USAGE WARNING****

This is a private computer system. This computer system, including all
related equipment, networks, and network devices (specifically including
Internet access) are provided only for authorized use. This computer system
may be monitored for all lawful purposes, including to ensure that its use
is authorized, for management of the system, to facilitate protection against
unauthorized access, and to verify security procedures, survivability, and
operational security. Monitoring includes active attacks by authorized entities
to test or verify the security of this system. During monitoring, information
may be examined, recorded, copied and used for authorized purposes. All
information, including personal information, placed or sent over this system
may be monitored.

Use of this computer system, authorized or unauthorized, constitutes consent
to monitoring of this system. Unauthorized use may subject you to criminal
prosecution. Evidence of unauthorized use collected during monitoring may be
used for administrative, criminal, or other adverse action. Use of this system
constitutes consent to monitoring for these purposes.
Password:"

But when I log in with my password, it just prints out
"Access denied"

This happens until I get locked out for "Too many authentication failures"
It will work when I SSH locally, using "$ssh debian"
 
Old 11-15-2017, 12:15 PM   #2
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,367

Rep: Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258
Possibly the keyboard layout on the server is different to your client? have you tried typing the password into something like notepad then pasting it into PuTTY?
edit: When my password is not accepted one of the first things I do is type it in the username field to ensure I am typing what I think I am typing.

Last edited by 273; 11-15-2017 at 12:16 PM.
 
Old 11-15-2017, 12:41 PM   #3
justsaucerawsauce
LQ Newbie
 
Registered: Nov 2017
Posts: 12

Original Poster
Rep: Reputation: Disabled
Apparently all I had to do is use a bridged network adapter (I'm on VirtualBox)
 
Old 11-15-2017, 12:58 PM   #4
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,367

Rep: Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258Reputation: 2258
Quote:
Originally Posted by justsaucerawsauce View Post
Apparently all I had to do is use a bridged network adapter (I'm on VirtualBox)
What is "on VirtualBox"?
Please give some details of what is installed an how. Or, do you mean that this is solved by using a bridged adapter and whant to know what that means?
 
Old 11-15-2017, 01:29 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,034

Rep: Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892Reputation: 2892
At face value what you posted does not make sense.

That weird message is a banner which is normally turned off by default. I can only assume that the hostname you were using was resolving to another IP address and obviously you could not login. A VirtualBox NAT adapter (default) acts like a typical home router. Without port forwarding you can not access a virtual machine. If trying to connect I would of expected a a no route to host or connection refused message.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ssh-keygen for auto ssh login not working R00ts Linux - Software 26 09-23-2012 01:40 PM
ssh key authentication not working (debian into redhat) Jangari Linux - Networking 5 08-29-2011 10:12 PM
SSH not working after ssh-keygen due to lack of entropy grob115 Linux - Security 8 08-28-2010 11:33 AM
Chroot SSH problem: ssh working, not SFTP & SCP. NaCo Linux - Security 3 02-01-2009 02:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration