-   Linux - Newbie (
-   -   ssh host key problem (

Amaranthus 12-14-2009 07:02 AM

ssh host key problem
I have a problem with a freshly installed openssh server on a MIPS based system (OpenWrt on ADM5120)
I can find both RSA and DSA host keys, but whenever I try to login the following error messages appear:

with putty:
Incoming packet was garbled on decryption

With tunnelier:
packet length toot large (267929772), may be decryption problem

I tried to generate new host keys, but nothing changed (except for the number in the error message of tunnelier)

The length of host keys are:

root@OpenWrt:/# ls -l /etc/ssh
-rw------- 1 root root 672 Jan 1 1970 ssh_host_dsa_key
-rw-r--r-- 1 root root 602 Jan 1 1970
-rw------- 1 root root 975 Jan 1 1970 ssh_host_key
-rw-r--r-- 1 root root 639 Jan 1 1970
-rw------- 1 root root 1675 Jan 1 1970 ssh_host_rsa_key
-rw-r--r-- 1 root root 394 Jan 1 1970
-rw-r--r-- 1 root root 3058 Sep 30 2007 sshd_config

sshd runs with defaults, the config file left intact after installation

Can anyone drop some hint that is this a misconfiguration or whatever ?
Thank you

immortaltechnique 12-14-2009 08:55 AM

For putty this is what it says on the FAQ's


10.9 "Incoming packet was garbled on decryption"

This error occurs when PuTTY decrypts an SSH packet and the decrypted data makes no sense. This probably means something has gone wrong in the encryption or decryption process. It's difficult to tell from this error message whether the problem is in the client or in the server.
I know this doesnt help much but have you tried a reinstallation?

AutoBot 12-14-2009 09:04 AM

Set the proper date/time and try again.

Amaranthus 12-14-2009 11:27 AM

Thank you for posting.
I reinstalled sshd - no change
After setting proper date/time - no change.
proper time - reinstall - new key generation - neither of them helped :-(

I tried to connect locally with ssh client from ttyS0 and it was successful :-o
Maybe the algorithm of generating key pairs is different from the standard?

Amaranthus 12-14-2009 12:31 PM

More additions:
When trying to connect with tunnelier the following messages scroll in the status window:

Starting a new SSH2 session
Connecting to SSH2 server
Starting first key exchange
Server version string: SSH-1.99-OpenSSH_4.5
New host key received. Algorithm: ssh-rsa, Size:2048 bits, MD5 Fingerprint:
95:ad:3d:1d:2b:50:70:9c:d6:98:95:f7:52:59:d1:65, Bubble-Babble:
First key exchange completed.
Key exchange:diffie-hellman-group14-sha1. Session encryption: aes256-ctr,
MAC:hmac-sha1, compression: none.
Session terminated on client's behalf:
packet length too large (1460763132), may be decryption problem

The fingerprint above is exact the same as it was appearing when I connected locally

Every idea is welcome what the heck the problem is

Amaranthus 12-15-2009 04:32 AM

Unfortunately, the problem still persists :-(
I discovered that sftp server was not installed despite that sshd_config had the reference to the nonexisting executable file.
However, correcting this did not solve the problem.
I browsed tons of google results on the subject which was obviously very useful, but not for the given problem.

You, guys can't be so heartless as leaving me alone with my stubborn OS, can you? :-)

Even condolences are welcome

evo2 12-15-2009 04:45 AM

Some things you can do to try to understand your problem.

- Look at the logs from sshd (but maybe no logging on OpenWRT)
- Run sshd manual in debug mode: outputs verbose info to terminal
- Try to connect using a proper ssh client from a remote machine



Amaranthus 12-15-2009 04:42 PM

Thank you very much for your advices.
I don't know, what the difference is between putty, and a Linux Mint ssh client that caused the error with putty.
I tried to connect with my notebook, which has a Mint8 installed and lo! ssh went smoothly.
It seems that there is some feature on a "normal" sshd which is not implemented in the OpenWrt version. Or simply the defaults are different. If the latter is the case, I have to figure out the correct settings.
I've been using putty for ages, without problems, whether connecting to a linux or a win ssh server.
However, I take this thread solved, since the ssh server works now.
Thank you again for your help.

All times are GMT -5. The time now is 04:05 PM.