LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2012, 06:42 PM   #1
juniglee
LQ Newbie
 
Registered: Jan 2012
Posts: 8

Rep: Reputation: Disabled
SSH failed authentication


Hi everyone,

I am not too familiar with Linux, and this is my first time setting up a Linux server. I am using Fedora 16, installed on Hyper-V virtual machine, and having problems with SSH access.

I have an administrator account, which is able to log in to the server properly when I do connect via virtual machine. If I try to use Putty with the same credentials, it consistently gives me an access denied error. This holds true for a test account I created as well.

In my /etc/ssh/sshd_config, I've disallowed logins as Root user, as well as disabled RSA, and enabled GSSAPI. Logging is set to:

SyslogFacility AUTHPRIV
LogLevel VERBOSE

Port is set to 22, Protocol is set to 2

I am pretty stumped at the moment, as I am following off the setting of another, working Linux server, which I'm able to SSH into fine.

Thanks for any help
 
Old 01-18-2012, 08:22 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
So what error messages does sshd put in the authentication logs when you try to log in? If it doesn't say anything useful, try setting the LogLevel to debug in /etc/ssh/sshd_config
 
Old 01-18-2012, 08:27 PM   #3
juniglee
LQ Newbie
 
Registered: Jan 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi Andrew thanks for the reply.

Where can I find the authentication logs?

EDIT: Nevermind, I found it, but doesn't seem like there's anything out of the ordinary.

Last edited by juniglee; 01-18-2012 at 09:04 PM.
 
Old 01-18-2012, 08:57 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Try /var/log/messages & /var/log/secure
 
Old 01-18-2012, 09:15 PM   #5
juniglee
LQ Newbie
 
Registered: Jan 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
The last few lines in /var/log/messages say

Jan 19 13:02:23 <name> dbus-daemon[732]: ** (fprintd:19019): WARNING **: fprint init failed with error -99
Jan 19 13:02:23 <name> dbus-daemon[732]: dbus[732]: [system] Activated service 'net.reactivated.Fprint' failed: Launch helper exited with unknown return code 157
Jan 19 13:02:23 <name> dbus[732]: [system] Activated service 'net.reactivated.Fprint' failed: Launch helper exited with unknown return code 157

The last few lines in /var/log/secure say

Jan 19 13:02:44 <name> sshd[18862]: Received signal 15; terminating.
Jan 19 13:02:44 <name> sshd[19035]: Set /proc/self/oom_score_adj from 0 to -1000
Jan 19 13:02:44 <name> sshd[19035]: debug1: Bind to port 22 on 0.0.0.0.
Jan 19 13:02:44 <name> sshd[19035]: Server listening on 0.0.0.0 on port 22.
Jan 19 13:02:44 <name> sshd[19035]: debug1: Bind to port 22 on ::.
Jan 19 13:02:44 <name> sshd[19035]: Server listening on :: port 22.
Jan 19 13:03:31 <name> sudo: administrator : TTY=tty1 ; PWD=/home/administrator ; USER=root ; COMMAND=/usr/bin/vim /etc/ssh/sshd_config
Jan 19 13:04:19 <name> sudo: administrator : TTY=tty1 ; PWD=/home/administrator ; USER=root ; COMMAND=/usr/bin/vim /var/log/messages
Jan 19 13:05:16 <name> sudo: administrator : TTY=tty1 ; PWD=/home/administrator ; USER=root ; COMMAND=/usr/bin/vim /var/log/messages
Jan 19 13:18:31 <name> sudo: administrator : TTY=tty1 ; PWD=/home/administrator ; USER=root ; COMMAND=/usr/bin/vim /var/log/secure

Not sure what to make of this, any help would be much appreciated. Please don't hesitate if you need more specific information, though you need to tell me what to look for because my Hyper-V connection does not have mouse capture, so I have to type out the relevant logs by hand.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh -L '>channel 3: open failed: connect failed:' Luke771 Linux - Networking 14 01-24-2012 04:14 AM
configure ssh authentication using password file and sftp/scp authentication using ld cameliab Linux - Software 1 08-29-2011 04:28 AM
[SOLVED] Failed SSH authentication with Radius Server sheelavantar Linux - Security 2 01-28-2011 07:35 AM
scp without authentication and ssh with authentication? bkcreddy17 Linux - Server 7 10-08-2008 02:33 AM
failed ssh RSA key authentication jdarren Linux - Networking 15 07-06-2008 11:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration