LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2010, 01:37 AM   #1
windstory
Member
 
Registered: Nov 2008
Posts: 486

Rep: Reputation: 36
ssh - debug3: no such identity:


I have a problem - "ssh - debug3: no such identity:"

I tried to connect copssh at 192.168.0.2 and centos 5.4. x86 ssh at 192.168.0.4.

At 192.168.0.2,

Code:
ssh-keygen -t rsa (for ddisk-net_pc_p without password)
At 192.168.0.4,
Code:
mkdir -p ddisk-net_pc
mkdir /home/ddisk-net_pc/.ssh
chown -R ddisk-net_pc:users ddisk-net_pc
chmod 700 /home/ddisk-net_pc
chmod 700 /home/ddisk-net_pc/.ssh
mv ddisk-net_pc.pub ddisk-net_pc_p
chmod 600 /home/ddisk-net_pc/.ssh/ddisk-net_pc_p
At 192.168.0.2,
Code:
ssh -i /home/ddisk-net_pc/.ssh/ddisk-net_pc_p ddisk-net@12.18.0.4
The debug result is here;
Quote:
Administrator@windstory-PC ~/.ssh
$ ssh -vvv ddisk-net_vb
OpenSSH_5.4p1, OpenSSL 0.9.8n 24 Mar 2010
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for ddisk-net_vb
debug2: ssh_connect: needpriv 0
debug1: Connecting to test.net [xxx.xxx.xx.xx] port 22.
debug1: Connection established.
debug1: identity file /home/ddisk-net/.ssh/ddisk-net_pc_p type -1
debug1: identity file /home/ddisk-net/.ssh/ddisk-net_pc_p-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.4
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-g
roup-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh
.com,ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour12
8,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rij
ndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour12
8,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rij
ndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: zlib@openssh.com,zlib,none
debug2: kex_parse_kexinit: zlib@openssh.com,zlib,none
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-gro
up14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@open
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@open
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 zlib@openssh.com
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 zlib@openssh.com
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 134/256
debug2: bits set: 533/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: host test.net filename /home/Administ
rator/.ssh/known_hosts
debug3: check_host_in_hostfile: host test.net filename /home/Administ
rator/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 3
debug3: check_host_in_hostfile: host xxx.xxx.xx.xx filename /home/Administrator/
.ssh/known_hosts
debug3: check_host_in_hostfile: host xxx.xxx.xx.xx filename /home/Administrator/
.ssh/known_hosts
debug3: check_host_in_hostfile: match line 3
debug1: Host 'test.net' is known and matches the RSA host key.
debug1: Found key in /home/Administrator/.ssh/known_hosts:3
debug2: bits set: 507/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/ddisk-net/.ssh/ddisk-net_pc_p (0x0)
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/ddisk-net/.ssh/ddisk-net_pc_p
debug3: no such identity: /home/ddisk-net/.ssh/ddisk-net_pc_p
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
ddisk-net@test.net's password:
Thanks in advance.

Last edited by windstory; 07-19-2010 at 01:40 AM.
 
Old 07-19-2010, 12:54 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
So is ddisk-net an actual identity or user on 192.168.0.4? I see that you created the directory structure in /home, I'm also assuming you copied the pub key over to this host when you created it on 192.168.0.2, but it has to be an actual user. More details get better responses.

In your debug, you have: Administrator@windstory-PC ~/.ssh
$ ssh -vvv ddisk-net_vb

What is this ddisk-net_vb?

Last edited by trickykid; 07-19-2010 at 12:57 PM.
 
1 members found this post helpful.
Old 07-19-2010, 08:31 PM   #3
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
trickykid/
1. yes. ddisk-net is user of 192.168.0.4.
2. I have made directories for ssh on 192.168.0.2 and 1921.168.0.4.
3. I made ssh.conf at "/etc/" of 192.168.0.2 as follows:

Quote:
host ddisk-net_vb
hostname test.net
user ddisk-net
port 22
identityfile /home/ddisk-net/.ssh/ddisk-net_pc_p
compression yes
protocol 2
 
Old 07-19-2010, 10:37 PM   #4
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
I resolved this problem in summarizing my question for checking trickykid's reply.

I found my mistake is identityfile's location. This should be client's directory.
 
1 members found this post helpful.
Old 06-30-2012, 10:42 AM   #5
rickumali
LQ Newbie
 
Registered: Jan 2006
Location: Arlington, MA, USA.
Posts: 3

Rep: Reputation: 0
Smile Renaming File Helped

This thread helped me out. My resolution was slightly different. I was getting:

Code:
debug1: Trying private key: rufirstpk.ssh
debug3: no such identity: rufirstpk.ssh
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
trickykid's question of whether the ID existed on the server made me question the filename, because 'rufirstpk' is not an identity or a user on the machine I'm trying to SSH to. I renamed the file to a correct user:

Code:
mv rufirstpk.ssh ec2-user.ssh
This change meant I had to change my .ssh/config:

Code:
Host et
HostName ec2.amazon.com
User ec2-user
IdentitiesOnly yes
IdentityFile ec2-user.ssh
To my delight, I was able to log in! I hope this variation of the resolution helps someone out!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh -i does not use my identity file? SibLiant Debian 2 11-05-2009 07:43 PM
How can I hide my identity while connected with ssh server kingkazmi1988 Linux - Newbie 2 11-09-2007 06:30 PM
ssh without identity files veeruk101 Linux - Networking 1 07-16-2007 10:04 PM
user identity oeivindh76 Linux - Security 1 10-06-2004 06:49 PM
identity crisis spedsta Linux - Networking 2 06-18-2004 12:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration